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请注意以下有关 Microchip 器件代码保护功能的要点：

• Microchip 的产品均达到 Microchip 数据手册中所述的技术指标。

• Microchip 确信：在正常使用的情况下， Microchip 系列产品是当今市场上同类产品中最安全的产品之一。

• 目前，仍存在着恶意、甚至是非法破坏代码保护功能的行为。就我们所知，所有这些行为都不是以 Microchip 数据手册中规定的

操作规范来使用 Microchip 产品的。这样做的人极可能侵犯了知识产权。

• Microchip 愿与那些注重代码完整性的客户合作。

• Microchip 或任何其他半导体厂商均无法保证其代码的安全性。代码保护并不意味着我们保证产品是 “牢不可破”的。

代码保护功能处于持续发展中。 Microchip 承诺将不断改进产品的代码保护功能。任何试图破坏 Microchip 代码保护功能的行为均可视

为违反了《数字器件千年版权法案 （Digital Millennium Copyright Act）》。如果这种行为导致他人在未经授权的情况下，能访问您的

软件或其他受版权保护的成果，您有权依据该法案提起诉讼，从而制止这种行为。
提供本文档的中文版本仅为了便于理解。请勿忽视文档中包含

的英文部分，因为其中提供了有关 Microchip 产品性能和使用

情况的有用信息。Microchip Technology Inc. 及其分公司和相

关公司、各级主管与员工及事务代理机构对译文中可能存在的
任何差错不承担任何责任。建议参考 Microchip Technology
Inc. 的英文原版文档。

本出版物中所述的器件应用信息及其他类似内容仅为您提供便

利，它们可能由更新之信息所替代。确保应用符合技术规范，
是您自身应负的责任。Microchip 对这些信息不作任何明示或

暗示、书面或口头、法定或其他形式的声明或担保，包括但不

限于针对其使用情况、质量、性能、适销性或特定用途的适用
性的声明或担保。 Microchip 对因这些信息及使用这些信息而

引起的后果不承担任何责任。如果将 Microchip 器件用于生命

维持和 / 或生命安全应用，一切风险由买方自负。买方同意在

由此引发任何一切伤害、索赔、诉讼或费用时，会维护和保障
Microchip 免于承担法律责任，并加以赔偿。在 Microchip 知识

产权保护下，不得暗中或以其他方式转让任何许可证。
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前言
简介

本章包含在使用 PICkit™ 2 之前需要了解的一般信息。本章讨论的内容包括：

• 文档编排

• 本指南使用的约定

• 保修登记

• 推荐读物

• Microchip 网站

• 开发系统变更通知客户服务

• 客户支持

客户须知

所有文档均会过时，本文档也不例外。 Microchip 的工具和文档将不断演变以满足客户的需求，因此
实际使用中有些对话框和 / 或工具说明可能与本文档所述之内容有所不同。请访问我们的网站
（www.microchip.com）获取最新文档。

文档均标记有“DS”编号。该编号出现在每页底部的页码之前。DS 编号的命名约定为“DSXXXXXA”，
其中“XXXXX”为文档编号，“A”为文档版本。

欲了解开发工具的最新信息，请参考 MPLAB® IDE 在线帮助。从 Help （帮助）菜单选择 Topics
（主题），打开现有在线帮助文件列表。
 2009 Microchip Technology Inc. DS51553E_CN 第 1 页
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文档编排

本文档介绍如何将 PICkit 2 用作开发工具在目标板上仿真和调试固件。本手册的内容编
排如下：

• 第 1 章 PICkit 2 编程器 / 调试器概述——提供 PICkit 2 编程器 / 调试器的概述。

• 第2章 PICkit 2编程器入门——说明如何开始使用PICkit 2编程器 /调试器对基于闪
存的 PIC® 单片机 （MCU）进行编程。

• 第 3 章 使用在线串行编程（ICSP™） ——说明如何使用在线串行编程（In-Circuit
Serial Programming™， ICSP™）通过 PICkit 2 编程器 / 调试器进行编程。

• 第4章 PICkit 2 Debug Express——提供如何使用PICkit™ 2 Debug Express调试
程序的教程。 

• 第 5 章 疑难解答——提供解决常见问题和 Debug Express 错误的信息。 
• 第6章 更新PICkit 2操作系统——说明如何更新PICkit 2编程器 /调试器的操作
系统。

• 第7章 PICkit 2 UART工具——说明如何使用PICkit 2作为串行UART终端接口与
PIC 单片机进行通信。 

• 附录A MPLAB IDE参考——说明PICkit 2编程器 /调试器如何与MPLAB IDE配合
工作。

• 附录 B PICkit 2 原理图——提供 PICkit 2 编程器 /调试器的硬件原理图。
DS51553E_CN 第 2 页  2009 Microchip Technology Inc.



前言
本指南使用的约定

以下约定可能出现在本文档中：

文档约定

说明 涵义 示例

Arial 字体：

斜体 参考书目 MPLAB® IDE User’s Guide

需强调的文字 ... 仅有的编译器 ...
首字母大写 窗口 Output 窗口

对话框 Settings 对话框

菜单选项 选择 Enable Programmer
引用 窗口或对话框中的字段名 “Save project before build”
带右尖括号且有下划线的斜体
文字

菜单路径 File>Save

粗体字 对话框按钮 单击 OK
选项卡 单击 Power 选项卡

尖括号 < > 括起的文字 键盘上的按键 按 <Enter>， <F1>
Courier New 字体：

常规 源代码示例 #define START

文件名 autoexec.bat

文件路径 c:\mcc18\h

关键字 _asm, _endasm, static

命令行选项 -Opa+, -Opa-

位值 0, 1

常数 0xFF,’A’

斜体 可变参数 file.o，其中 file可以是任
一有效文件名

方括号 [ ] 可选参数 mpasmwin [options] 
file [options]

花括号和竖线： { | } 选择互斥参数；“或”选择 errorlevel {0|1}

省略号 ... 代替重复文字 var_name [, 
var_name...]

表示由用户提供的代码 void main (void)
{ ...
}

 2009 Microchip Technology Inc. DS51553E_CN 第 3 页
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保修登记

请填写随附的保修登记卡（Warranty Registration Card）并尽快寄出。寄出保修登记卡
的用户将可收到新产品更新信息。临时发布的软件在 Microchip 网站上提供。

推荐读物

本用户指南介绍如何使用 PICkit 2。下面列出了其他有用的文档。Microchip 提供了如下
文档，推荐将这些文档作为补充参考资料。

44-Pin Demo Board User’s Guide （DS41296）
要了解如何将44引脚演示板用作开发工具在目标板上仿真和调试固件，请查阅此文档。

低引脚数演示板用户指南 （DS51556A_CN）

要了解如何使用 Microchip Technology 的低引脚数器件（8 引脚、14 引脚和 20 引脚），
请查阅此文档。其中包含一系列教程。

MPLAB® IDE 快速入门指南 （DS51281G_CN）

说明如何设置 MPLAB IDE 软件，以及如何用它创建项目和对器件编程。

MPLAB® IDE 用户指南 / 帮助 （DS51519A_CN）

要详细了解 MPLAB 集成开发环境（Integrated Development Environment， IDE）软件
的安装和功能，请查阅此文档。还提供了在线帮助版本。

In-Circuit Serial Programmer™ (ICSP™) Guide （DS30277）
本文档中的设计指导将帮助您成功进行 ICSP 编程。其中包括硬件设计方面的应用笔记
和 ICSP 编程规范。

MPASM™ 汇编器、 MPLINK™ 目标链接器、 MPLIB™ 目标库管理器用户指南
（DS33014J_CN）

说明如何使用 Microchip 的 PIC® MCU 汇编器（MPASM 汇编器）、链接器（MPLINK
链接器）和库管理器 （MPLIB 库管理器）。

PICkit™ 2 Debug Express 的自述文件

关于使用 PICkit 2 Debug Express 的最新信息，请阅读 “Readme for PICkit
2.htm”文件（HTML文件），该文件位于MPLAB IDE安装目录的Readmes子目录下。
自述文件包含了本用户指南中可能未提供的更新信息和已知问题。

自述文件

关于使用其他工具的最新信息，请阅读与该工具相关的自述文件，文件位于MPLAB IDE
安装目录的 Readmes 子目录下。自述文件包含本用户指南中可能未提供的更新信息和
已知问题。
DS51553E_CN 第 4 页  2009 Microchip Technology Inc.
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MICROCHIP 网站

Microchip 网站 （www.microchip.com）为客户提供在线支持。客户可通过该网站方便
地获取文件和信息。只要使用常用的因特网浏览器即可访问。网站提供以下信息：

• 产品支持——数据手册和勘误表、应用笔记和示例程序、设计资源、用户指南以及
硬件支持文档、最新的软件版本以及存档软件

• 一般技术支持——常见问题（FAQ）、技术支持请求、在线讨论组以及 Microchip 顾
问计划成员名单

• Microchip业务——产品选型和订购指南、最新Microchip新闻稿、研讨会和活动安
排表、 Microchip 销售办事处、代理商以及工厂代表列表

开发系统变更通知客户服务

Microchip 的客户通知服务有助于客户了解 Microchip 产品的最新信息。注册客户可在
他们感兴趣的某个产品系列或开发工具发生变更、更新、发布新版本或勘误表时，收到
电子邮件通知。

欲注册，请登录 Microchip 网站 www.microchip.com，点击“变更通知客户（Customer
Change Notification）”服务后按照注册说明完成注册。

开发系统产品的分类如下：

• 编译器——Microchip C 编译器及其他语言工具的最新信息，包括 MPLAB C18 和
MPLAB C30 C编译器、MPASM™和MPLAB ASM30汇编器、MPLINK™和MPLAB
LINK30 目标链接器，以及 MPLIB™ 和 MPLAB LIB30 目标库管理器。

• 仿真器——Microchip在线仿真器的最新信息，包括MPLAB REAL ICE™和MPLAB
ICE 2000 在线仿真器。

• 在线调试器——Microchip在线调试器的最新信息，包括MPLAB ICD 2和PICkit™ 2。
• MPLAB® IDE——关于支持 Microchip 开发系统工具的 Windows® 集成开发环境

MPLAB IDE的最新信息，主要针对MPLAB IDE、MPLAB IDE项目管理器、MPLAB
编辑器、 MPLAB SIM 模拟器以及一般编辑和调试功能。

• 编程器——Microchip 编程器的最新信息，包括 MPLAB PM3 器件编程器以及
PICSTART® Plus、 PICkit 1 和 PICkit 2 开发编程器。
 2009 Microchip Technology Inc. DS51553E_CN 第 5 页
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客户支持

Microchip 产品的用户可通过以下渠道获得帮助：

• 代理商或代表

• 当地销售办事处

• 应用工程师 （FAE）
• 技术支持

客户应联系其代理商、代表或应用工程师（FAE）寻求支持。当地销售办事处也可为客
户提供帮助。本文档后附有销售办事处的联系方式。请访问我们的网站获取完整、最新
的销售办事处列表。

也可通过 http://support.microchip.com 获得网上技术支持。
DS51553E_CN 第 6 页  2009 Microchip Technology Inc.
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第 1 章  PICkit 2 编程器 / 调试器概述
1.1 简介

本章介绍 PICkit 2 开发编程器 / 调试器的特性和 PICkit 2 编程器应用程序的菜单功能。

本章内容包括：

• PICkit 2 开发编程器 / 调试器内容

• PICkit 2 开发编程器 / 调试器

• PICkit 2 编程器应用程序

1.2 PICkit 2 开发编程器 / 调试器内容

PICkit 2 开发编程器 / 调试器工具包包含以下组件：

1. PICkit 2 开发编程器 / 调试器

2. USB 电缆

3. PICkit Starter Kit 和 MPLAB IDE CD-ROM
此外，PICkit 2 Starter Kit 和 PICkit 2 Debug Express 工具包都包含一个带有 PIC 单片
机的演示板。

1.3 PICkit 2 开发编程器 / 调试器

PICkit 2 开发编程器 / 调试器是一款低成本开发编程器。它能够对 Microchip 的大多数
闪存单片机和串行EEPROM器件编程。要了解支持的具体器件，请参见PICkit 2 Starter
Kit CD-ROM 中的 README文件。

通过更新编程软件可增加对新器件的支持。最新的软件可从 Microchip 网站中的 PICkit 2
页面获取：www.microchip.com/pickit2。
PICkit 2 还可用于对选定器件进行调试。更多详细信息，请参见第 4 章“PICkit 2 Debug
Express”。

注： PICkit 2 旨在用于开发编程。对于生产编程，请选用 MPLAB PM3 器件编程
器，或者为生产环境设计的其他第三方编程器。
 2009 Microchip Technology Inc. DS51553E_CN 第 7 页

http://www.microchip.com/pickit2


PICkit™ 2 用户指南
图 1-1 中给出了 PICkit 2 设备的图示。

图 1-1： PICkit™ 2 MCU 编程器 / 调试器

1.3.1 USB 端口连接

此USB端口连接为USB微型B连接器。请使用附带的USB电缆将PICkit 2 连接到PC。

1.3.2 状态 LED
状态 LED 可指示 PICkit 2 的状态。

1. Power （绿色） ——PICkit 2 已通过 USB 端口上电。

2. Target （黄色）——PICkit 2 正在向目标器件供电。

3. Busy （红色）——PICkit 2 正忙于处理某项功能，例如编程。

1.3.3 按钮

如果在 PICkit 2 编程器应用程序菜单中选中了 Programmer>Write on PICkit Button（编
程器 > 按下 PICkit 按扭时写），此按钮可用于启动 Write Device（烧写器件）编程功能
（见图 1-1 中标记为 2 的项）。 
此按钮还可用于使 PICkit 2 设备操作系统固件进入自举程序模式。关于此功能的更多信
息，请参见第 6 章 “更新 PICkit 2 操作系统”。

1.3.4 编程连接器

编程连接器是一个 6 引脚插头（0.100" 间距），用于连接到目标器件。引脚排列规范，
请参见图 1-2。 
要进一步了解如何使用 PICkit 2 进行在线串行编程 （ICSP），请参见第 3 章 “使用在
线串行编程 （ICSP™）”。

1

2

4

3

56

图例：

1 －状态 LED 3 －挂绳连接 5 －引脚 1 标记

2 －按钮 4 － USB 端口连接 6 －编程连接器
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图 1-2： PICkit™ 2 编程器连接器引脚排列

1.3.5 挂绳连接

为避免丢失 PICkit 2，编程器上提供了方便的挂绳连接孔。

1
2
3
4
5
6

* 此 6 引脚插头（0.100" 间距）可连接 0.025" 的方形引脚。

引脚说明 *
1 = VPP/MCLR
2 = VDD 目标电源

3 = VSS （地）

4 = ICSPDAT/PGD
5 = ICSPCLK/PGC
6 = 备用

引脚 1 指示标记

注： 对串行 EEPROM 和 HCS 器件进行编程时，编程连接器的引脚功能是不同
的。关于这些引脚排列，请参见随 PICkit 2 编程软件包含的自述文件
（Help>Readme）。
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1.4 PICkit 2 编程器应用程序

PICkit 2编程器应用程序允许您对PICkit 2自述文件中列出的所有受支持器件进行编程。
编程界面如图 1-3 所示。以下几节中列出了它的控件。

关于如何安装和使用 PICkit 2 编程器应用程序的更多信息，请参见第 2 章“PICkit 2 编
程器入门”。

图 1-3： PICkit™ 2 编程器应用程序

菜单栏

状态窗口

进度条

程序存储器

器件配置

EEPROM 数据存储器

存储器源

器件 VDD
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PICkit 2 编程器 / 调试器概述
1.4.1 菜单栏

可在菜单栏中选择PICkit 2编程器应用程序的各种功能。以下是对这些功能的概括说明：

File （文件）

• Import Hex（导入Hex）——导入用于编程的 hex文件。支持hex文件格式 INHX32。
• Export Hex（导出 Hex）——导出从器件读取的 hex 文件。hex 文件以 INHX32 格式
创建。

• File History（文件历史记录）——最多可显示 4 个最后打开的 hex 文件，并显示它们
的文件路径。选择这些最近的 hex 文件可以快速地导入它们。请注意，在新的安装
中，文件历史最初将显示为空，直到导入某个 hex 文件为止。

• Exit （退出）——退出程序。

Device Family （器件系列）

选择某一器件系列以搜索该系列中连接的器件。选择当前器件的器件系列会将所有器件
数据清除。

对部分无法自动检测的系列（例如低档系列），会出现一个下拉框，从中可以选择支持
的器件。

Programmer （编程器）

• Read Device（读器件）——读取程序存储器、数据 EEPROM 存储器、ID 单元和配
置位。

• Write Device（烧写器件）——写入程序存储器、数据 EEPROM 存储器、ID 单元和
配置位。

• Verify（校验）——用编程应用程序中保存的代码校验从目标 MCU 读取的程序存储
器、数据 EEPROM 存储器、 ID 单元和配置位。

• Erase（擦除）——执行目标 MCU 的批量擦除。保留 OSCCAL 和带隙值（对于具有
这些特性的器件）。

• Blank Check（空白检查）——执行程序存储器、数据 EEPROM 存储器、ID 单元和
配置位的空白检查。

• Verify on Write （写校验）——选中时，器件会在编程后立即进行写校验（推荐）。
未选中时，将对器件编程但不进行写校验。

• Hold Device in Reset （保持器件复位）——选中时， MCLR （VPP）引脚保持低电
平 （有效）。未选中时，引脚被释放 （三态），外部上拉可使器件脱离复位状态。

• Write on PICkit Button（按下 PICkit 按钮时写）——选中时，按下 PICkit 2 按钮将启
动写操作。

Tools （工具）

• Enable Code Protect （使能代码保护）——允许单片机在以后执行写操作时使用代
码保护功能。

• Enable Data Protect（使能数据保护）——允许单片机在以后对数据 EEPROM 存储
器执行写操作时使用数据保护功能。

注： 要禁止代码保护，必须擦除并重新写入所有器件存储器。

注： 要禁止数据保护，必须擦除并重新写入所有器件存储器。
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• Set OSCCAL（设置 OSCCAL）——对于将 OSCCAL 值存储在最后一个程序存储单
元的器件，允许修改 OSCCAL 值。

• Target VDD Source （目标 VDD 源）

- Auto-Detect （自动检测）——PICkit 2 每次操作时会自动检测目标器件有无自
己的电源，或是否需要编程器供电。

- Force PICkit 2 （强制 PICkit 2 供电）——PICkit 2 会始终尝试用 VDD 对目标器
件供电。

- Force Target （强制目标供电）——PICkit 2 总是假定目标器件有自己的电源。

• Calibrate VDD & Set Unit ID（校准 VDD 与设置设备 ID）——打开一个向导，它会指导
用户校准 PICkit 2 VDD 提供的电压，使之更精确，（可选）并指定设备 ID 来识别多
个 PICkit 2 设备。

• Use VPP First Program Entry（使用 VPP 第一个编程入口）——选中时，它使 PICkit 2
可以连接到器件，并使用会影响 ICSP 信号引脚的配置和代码对器件进行编程，并防
止 PICkit 2 检测到它们。使用该功能时，要求 PICkit 2 为目标器件提供 VDD。

• Fast Programming（快速编程）——选中时，PICkit 2 将尝试对器件进行快速编程。
未选中时，PICkit 2 会使 ICSP 通信变慢。这可能对 ICSP 线带负载的目标器件有帮
助。

• Check Communication（检查通信）——通过尝试用器件 ID 识别所连接的器件，检
查它与 PICkit 2 的 USB 通信，以及与目标器件的 ICSP 通信。

• UART Tool...（UART工具）——使PICkit 2进入UART模式，并打开一个类似于终端
的界面，用于通过 USART 引脚与 PIC MCU 器件程序进行通信。更多信息，请参见
第 7 章“PICkit 2 UART 工具”。

• Troubleshoot...（疑难解答）——打开向导，协助解决有关 PICkit 2 与目标器件连接
的问题。这在编程器根本无法检测到目标器件时最有用。

• Download PICkit 2 Programmer Operating System（下载 PICkit 2 编程器操作
系统）—— 下载 PICkit 2 操作系统 （固件）。

Help （帮助）

• PICkit 2 User’s Guide（PICkit 2用户指南）——尝试打开本用户指南的PDF文件（必
须装有 Adobe® Reader）。

• 44-Pin Demo Board Guide（44 引脚演示板指南）——尝试打开 44-Pin Demo Board
User’s Guide 的 PDF 文件 （必须装有 Adobe Reader）。

• LPC Demo Board Guide （LPC 演示板指南）——尝试打开 Low Pin Count Demo
Board User’s Guide 的 PDF 文件 （必须装有 Adobe Reader）。

• PICkit 2 Programmer on the web（PICkit 2 编程器网上信息）——用默认的网络浏览
器打开 www.microchip.com/pickit2。 

• Readme （自述文件）——打开 PICkit 2 的 Readme.txt文件。

• About（关于）——打开一个对话框，其中包含 PICkit 2 编程器应用程序版本、器件
文件版本和固件版本。

1.4.2 器件配置

器件配置窗口显示 Device（器件）、User ID（用户 ID）、Configuration Word（配置
字）和 Checksum （校验和）。此窗口中还显示 OSCCAL 和 Band Gap （带隙），这
两项仅针对有这些特性的器件。

对于低档 （12 位内核）器件、串行 EEPROM 器件和 KeeLoq® HCS 器件，您必须从
Device 下拉菜单中选择器件。
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所有其他器件系列的器件都通过它们的器件 ID 检测，器件名会显示在 Device 行中。

1.4.3 状态窗口

状态窗口以文本显示当前操作的状态。如果操作成功，则状态窗口会显示绿色背景。如
果操作失败，则状态窗口会显示红色。如果操作引起警告提示，则状态窗口会显示黄色。

1.4.4 进度条

进度条显示操作的进度。

1.4.5 器件 VDD

可通过单击复选框 “On”来打开和关闭 PICkit 2 的 VDD。通过在右边框中直接输入或
者用上下箭头调节 （每次 1/10 伏）来设置该电压。允许的最高和最低电压随目标器件
不同而有所变化。

如果未选中 “On”复选框， PICkit 2 会在请求的任何编程操作中，自动按设置的电压
打开 VDD。

图 1-4： PICKIT™ 2 提供的 VDD

如果目标器件有自己的电源，则 PICkit 2 会在右边的框中显示检测到的 VDD 电压，此
框将被灰掉以防被更改。复选框文字变为 “Check”（检查），单击该复选框会更新检
测到的 VDD 电压值。如果选择了 Target VDD>Auto-Detect（目标 VDD> 自动检测），且
未检测到目标电源，单击该复选框会将 VDD 模式回复到 PICkit 2 提供的 VDD。

图 1-5： 目标器件提供的 VDD

1.4.6 器件 MCLR 状态

图 1-4 和图 1-5 中显示的 “/MCLR”复选框与菜单选项 Programmer>Hold Device in
Reset 具有相同的功能。选中该复选框时，目标器件将保持在复位状态。未选中时，允

许目标电路将 MCLR 上拉至 VDD 来将器件从复位状态释放。该功能可用于阻止器件在

编程之前和之后执行代码。

注： 如果目标器件允许 MCLR 引脚配置为输入端口，并且也是如此配置， PICkit 2
将无法将器件保持在复位状态。
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1.4.7 存储器源

Source（源）栏显示当前装入的器件数据的来源。如果从 hex 文件读取，会显示 hex 文
件的名称。如果从器件读取，会显示器件名称。 None (Empty/Erased)（无（空 /
擦除））表示缓冲区为空，在窗口中编辑 Program Memory（程序存储器）或 EEPROM
Data （EEPROM 数据）后将显示 Edited（已编辑）。

1.4.8 程序存储器

程序代码可以通过两种方式加载到 PICkit 2 编程器应用程序中：选择 File>Import HEX
导入一个 hex 文件，或单击 Read 来读取器件存储器内容。代码的来源显示在 Source
框中。 Program Memory 窗口显示十六进制的程序代码。在此窗口中不能编辑代码。

Program Memory 窗口旁的复选框仅针对具有 EEPROM 数据存储器的器件提供。如果
选中该框，则程序存储器、用户 ID 和配置字将写入该器件、从该器件读取，并在该器
件上校验。如果未选中该框，则程序存储器、用户 ID 和配置字在写器件操作中不会被
擦除或更改，也不会被读取或校验。该复选框不影响擦除器件或空白检查操作。不能同
时清除两个存储器窗口复选框。

对于受支持的串行 EEPROM 器件，器件内容将显示在 Program Memory 窗口，而不是
EEPROM Data 窗口中，以便于在更大的显示区域中查看。

1.4.9 数据 EEPROM 存储器

类似于上面的程序存储器，数据 EEPROM 代码也可以通过两种方式加载到 PICkit 2 编
程器应用程序中：选择 File>Import HEX 导入一个 hex 文件，或单击 Read 来读取器件
存储器内容。代码的来源显示在 Source 框中。 EEPROM Data 窗口显示十六进制的程
序代码。在此窗口中不能编辑代码。

EEPROM Data 窗口旁的复选框控制是否写、读和校验 EEPROM 数据存储器。如果选
中该框，则器件的 EEPROM 将由窗口数据覆盖。如果未选中该框，则器件的 EEPROM
在写器件操作中不会被擦除或更改。该复选框不影响擦除器件或空白检查操作。不能同
时清除两个存储器窗口复选框。
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第 2 章  PICkit 2 编程器入门
2.1 简介

本章介绍如何开始使用 PICkit 2 编程器 / 调试器对基于闪存的 PIC 单片机 （MCU）进
行编程。

要了解如何通过 PICkit 2 进行在线串行编程（ICSP™），请参见第 3 章 “使用在线串
行编程 （ICSP™）”。

要了解如何更新 PICkit 2 操作系统（固件），请参见第 6 章“更新 PICkit 2 操作系统”。

要了解关于在 MPLAB IDE 中使用 PICkit 2 作为调试器的信息，请参见第 4 章“PICkit 2
Debug Express”。
• 安装 PICkit 2 硬件

• 安装和启动 PICkit 2 编程器应用程序

• 连接至器件

• 选择目标电源

• 导入 Hex 文件

• 将程序烧写到器件中

• 校验器件

• 读器件存储器

• 器件代码保护

• 擦除和空白检查器件

• 自动进行读 / 写过程

2.2 安装 PICkit 2 硬件

安装 PICkit 2 硬件：

• 将 USB 电缆的一端插入 PICkit 2 USB 连接器。将另一端插入 PC 的 USB 端口。

• 通过 6 引脚连接器将 PICkit 2 连接到目标板。目标板可以是附带的演示板，也可以
是配有相应 6 引脚连接器的任意目标板。

• 对于自身带有电源的目标板，如果 PICkit 2 未连接到供电 USB 端口，则不要将
PICkit 2 与目标板连接。

• 对于具有 MPLAB ICD 2 形式的 RJ-11 连接器的目标板，要将 PICkit 2 与之连接，
将需要 AC164110 RJ-11 － ICSP 适配器工具包。

将 PICkit 2 插入 USB 时，建议先将它从所有目标板断开。类似地，当启动或重新启动
主机 PC 时，请确保将它从目标板断开。

关于 PICkit 2 硬件的更多信息，请参见第 1.3 节 “PICkit 2 开发编程器 / 调试器”。
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2.3 安装和启动 PICkit 2 编程器应用程序

将 PICkit 2 Starter Kit CD-ROM 插入 CD-ROM 驱动器。片刻后，将显示介绍性屏幕。
按照屏幕上的指示安装 PICkit 2 编程器应用程序。

如果未显示介绍性屏幕，则浏览至 CD-ROM 目录并打开
PICkit_Starter_Kit_Welcome.htm文件。

安装之后，通过选择开始 > 程序 >Microchip>PICkit 2 来启动 PICkit 2 编程器应用程序。
编程界面如图2-1所示。第1.4节“PICkit 2编程器应用程序”中列出了它的特性和功能。

图 2-1： PICkit™ 2 编程应用程序

2.4 连接至器件

PICkit 2 能够对多种基于闪存的 Microchip PIC 单片机和串行 EEPROM 器件进行编程。
CD-ROM 中的 PICkit 2 自述文件中列出了受支持的器件，该文件也可通过选择
Help>Readme 查看。

首次打开 PICkit 2 编程器应用程序时，它会尝试根据器件 ID 识别所连接的器件，并将
它显示在配置窗口中，如图 2-2 所示。
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图 2-2： 识别器件

如果目标板上的器件未能正确识别，则在尝试重新选择或更改器件之前，请检查目标板
电源 （第 2.5 节 “选择目标电源”）和器件 ICSP 连接。

任何时候都可以选择器件系列，搜索该系列中连接的器件。要在应用程序运行后连接到
某个器件，可单击如图 2-3 所示的 Device Family 菜单，选择器件系列。

图 2-3： 选择器件系列

如果选择了低档（12 位内核）、KEELOQ® HCS 或 EEPROM 器件系列，则必须从器件
下拉框中选择具体器件，如图 2-4 所示。这些器件不具有器件 ID，不支持自动检测。

警告

请确保选择了正确的低档器件。这些器件不包含用以确认器件选择的器件 ID。如果选择了错误

的低档器件，则可能会导致擦除最后一个存储单元中存储的 OSCCAL 值。
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图 2-4： 选择低档闪存器件

2.5 选择目标电源

PICkit 2 可以为目标板供电，目标板也可以从外部供电。

2.5.1 目标板由 PICkit 2 供电

如果计划从 PICkit 2 为目标板供电，则不要为目标板连接电源，否则 PICkit 2 将检测到
该电源，并且不会显示使用 PICkit 2 电源的选项。对于未连接外部电源的目标板，将可
以看到图 2-5 中显示的选项。

图 2-5： 由 PICkit™ 2 供电

要向目标器件供电，请选中 VDD PICkit 2 “On”复选框。默认设置是 “Off”，即不选
中该复选框。

可通过调节 VDD PICkit 2 电压框 （图 2-5），在使能电源之前或之后调节对目标器件提
供的电压。

如果在编程器提供的 VDD 上检测到短路或很大的电流负载，那么将会显示一个错误，并
且 VDD 会被自动禁止。 请参见图 2-6。

电压框

注： 如果未检测到目标电源，PICkit 2 将在编程期间始终对目标器件供电，无论
VDD PICkit 2 “On”复选框状态如何。

警告

USB 端口电流限制设定为 100 mA。如果目标板和 PICkit 2 的电流之和超出了此电流

限制，则 USB 端口将关闭。如果目标板需要更大功率，则可由外部电源供电。
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图 2-6： VDD 错误

为避免发生电流负载过大错误，建议将目标电流消耗保持在 25 mA 以下。过大的 VDD 电
容也应避免，因为它们会延长 VDD 的上升时间。允许的 VDD 上升时间是 500 µs 或更短。

2.5.2 目标器件由外部电源供电

目标器件也可以从外部供电。默认情况下，PICkit 2 会自动检测外部供电的电路板。标
题“VDD PICkit 2”将变为“VDD Target”，“On”复选框将替换为名为“Check”的
复选框，检测到的 VDD 电压显示在灰掉的电压框中，如图 2-7 所示。

单击 “Check”复选框将更新电压框中显示的检测到的 VDD 电压。如果单击该复选框
时未检测到 VDD 电压，则 PICkit 2 将恢复对目标器件提供 VDD 电源。

图 2-7： 外部供电的目标器件

2.6 导入 HEX 文件

要导入将烧写到目标器件中的已编译程序 （hex 文件），请选择 File>Import HEX，如
图 2-8 所示。

图 2-8： 导入 HEX 文件

示例源代码和 hex 文件位于 PICkit 2 Starter Kit CD-ROM 中的相应工具包演示板的
Install\Lessons\目录中。将使用文件夹 07 Reversible中的 hex 文件
Reversible.hex。

注： PICkit 2可用的最高外部VDD是5.0V。PICkit 2可用的最低外部VDD是2.5V。
 2009 Microchip Technology Inc. DS51553E_CN 第 19 页



PICkit™ 2 用户指南
浏览至 hex 文件，然后单击 Open （打开）。此时在 Program Memory 和 EEPROM
Data 窗口中显示代码。 hex 文件的名称显示在 Program Memory 下的 Source 框中。

图 2-9： 示例 HEX 文件已导入

如果 hex 文件不包含任何配置字， PICkit 2 编程器应用程序将警告您。可以通过在
MPLAB IDE 中选择 File>Export 保存 hex 文件 （包括配置存储区），确保 hex 文件中
包含了这些内容。（关于 MPLAB IDE 的用法，请参见第 4 章 “PICkit 2 Debug
Express”）。

如果 hex 文件包含当前器件中不存在的存储单元，您也会收到指出 hex 文件大于选定器
件存储容量的警告。不存在的存储单元的任何数据都不会导入。

2.7 将程序烧写到器件中

选择器件系列并导入 hex 文件后，单击 Write（图 2-10），可对目标器件进行编程。此
时将擦除器件并以之前导入的 hex 代码对器件编程。

注： 示例课程代码需要使用 CD-ROM 目录 Install/Lessons/中的 Setup 文
件从 CD-ROM 安装到本地硬盘中。附带工具包演示板的用户指南中介绍了
这些课程，在使用课程项目和源代码之前，应当先阅读该指南。
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PICkit 2 编程器入门
在编程期间擦除器件时，将使用批量擦除方法。对于批量擦除，所有中低档器件、以及
许多 dsPIC30F 和 PIC18F 器件都具有最小 VDD 的要求。其中的一部分器件支持低电压
行擦除方法，该方法可以在较低电压下使用，但擦除器件需要的时间较长。关于支持该
功能的器件，请参见自述文件（Help>Readme）。如果器件不支持行擦除，则器件 VDD
低于批量擦除所要求的最小电压时，将会弹出一个对话框来警告您。 

图 2-10： 按钮——WRITE

器件配置窗口下面的状态条会显示“烧写”操作的状态。如果烧写成功，状态条会变绿
并显示 “Programming Successful”（烧写成功），如图 2-11 所示。

图 2-11： 烧写成功状态

如果烧写失败，状态条会变红并显示“Programming Failed”（烧写失败），如图 2-12
所示。此错误指示编程过程中数据被破坏。如果显示此错误，请重新尝试将程序烧写到
器件中。如果依然出错，请参见第 5 章 “疑难解答”以获取帮助。

图 2-12： 烧写错误状态

其他烧写问题将显示为警告，并将状态条改变为黄色，如图 2-13 所示。在此例中，PICkit 2
和演示板已经断开。

注： 如果目前对器件设置了任何代码保护、数据保护、写保护或读保护配置位，
则在编程之前必须使用批量擦除方法。使用较低电压的行擦除过程将不会
成功。
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图 2-13： 烧写警告状态

2.7.1 烧写到特定存储区

如果某器件有 EEPROM 数据存储器，则 Program Memory 和 EEPROM Data 旁的
“Enabled”（使能）复选框将变为可用。 
这些复选框用于选择哪些存储区的编程操作将受影响。关于编程操作如何受这些复选框
影响的说明，请参见表 2-1。 Erase 和 Blank Check 总是针对所有存储区。

在写操作中，器件中不受影响的存储区将保持不变。

例如，如果Program Memory未选中而EEPROM Data选中，则写操作仅写入EEPROM
数据，而器件中的程序存储器、用户 ID 和配置字都保持不变。

如果 Program Memory 选中而 EEPROM Data 未选中，则写操作将烧写程序存储器、
用户 ID 和配置字，而器件中的 EEPROM 数据保持不变。

由于部分器件中的编程限制，PICkit 2 编程器应用程序会在写操作过程中读取并重新写
入 EEPROM 数据存储器，以保护其内容。

两个存储区都不选中是不允许的。

2.7.2 自动重载文件

在每次烧写前，会将导入的 hex 文件的时间戳与磁盘上的版本进行比较。如果磁盘上的
版本更新，则重新载入此文件。只有在已经从磁盘读取hex文件的情况下，才有此功能。

这个功能可确保将编译的最新版本烧写到器件中。该功能可以与 Tools>Program on
PICkit Button 功能配合使用，此时只需按下 PICkit 2 设备上的按钮，就可以烧写最新的
MPLAB IDE 编译版本，而无需切换到 PICkit 2 编程器软件。

表 2-1： 存储区选择

程序存储器使能 EEPROM 数据使能 写 / 读 / 校验 擦除 / 空白检查

选中 选中 所有存储区 所有存储区

选中 — 程序存储器
用户 ID
配置字

所有存储区

— 选中 仅 EEPROM 所有存储区

— — 不允许
DS51553E_CN 第 22 页  2009 Microchip Technology Inc.



PICkit 2 编程器入门
2.8 校验器件

校验功能用于验证器件存储器中的程序是否与导入PICkit 2 编程器应用程序的 hex文件
匹配。此功能比较存储器的所有区域，包括程序存储器、数据 EEPROM 存储器、ID 和
配置位。

要对代码进行校验，请导入 hex 文件并单击 Verify 按钮 （图 2-14）。 
请注意，如果选中了 Programmer>Verify on Write，则会自动对烧写操作进行校验。

图 2-14： 按钮——VERIFY

如果代码相同，状态条将变绿并显示 “Device Verified”（器件已校验）。如果发现不
同，状态条将变红并显示出错位置：“Error in Program Memory, Data EEPROM
Memory, or Configuration Bits”（程序存储器、数据 EEPROM 存储器或配置位出错）。

表 2-1 例举了校验如何受到存储区复选框的影响。

2.9 读器件存储器

要查看烧写到器件的代码，请单击 Read （图 2-15）。

图 2-15： 按钮——READ

此时在 Program Memory 和 EEPROM Data 窗口中显示代码，以供您查阅。如果显示
为全零，则器件可能被代码保护了 （见第 2.10 节 “器件代码保护”）。

表 2-1 例举了读操作如何受到存储区复选框的影响。 

2.10 器件代码保护

“代码和数据保护”功能使能器件的读保护功能。要保护程序存储器代码，请完成以下
步骤：

1. 导入 hex 文件。

2. 选择 Tools>Enable Code Protect，如图 2-16 所示。

3. 单击 Write。
具有EEPROM数据存储器的器件可通过选择Tools>Enable Data Protect保护EEPROM。
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图 2-16：  使能代码保护

2.11 擦除和空白检查器件

擦除功能会擦除程序存储器、数据 EEPROM 存储器、 ID 和配置位，无论 Program
Memory 和 EEPROM Data “Enabled”复选框状态如何。但是，一般情况下不需要此
功能，因为 “烧写”功能在对器件进行编程之前就已执行了擦除操作。

要擦除器件，请单击 Erase （图 2-17）。

图 2-17： 按钮——ERASE

空白检查功能会读整个器件，以确定程序存储器、EEPROM 数据存储器、用户 ID 和配
置位是否已擦除。所有存储区都会检查，无论 Program Memory 和 EEPROM Data
“Enabled”复选框状态如何。

要对器件进行空白检查，请单击 Blank Check （图 2-17）。

2.12 自动进行读 / 写过程

PICkit 2 编程器应用程序具有两个用于自动进行多个功能的按钮。

注： 如果读取已被保护的器件，受保护的存储区将显示全零。
仅仅取消选中 “Enable Code Protect”并不会允许您读取存储区。您必须
擦除并重新烧写所有器件存储器，然后才能再次读取该存储区。

注： PICkit 2 擦除功能始终使用批量擦除方法，该方法具有最小 VDD 要求，即使
是对于烧写功能支持行擦除的器件。如果 VDD 低于所连接器件的最小值要
求，您将收到警告。
DS51553E_CN 第 24 页  2009 Microchip Technology Inc.



PICkit 2 编程器入门
图 2-18： 自动操作按钮

2.12.1 Auto Import Hex + Write Device 按钮

该功能允许 PICkit 2 编程器应用程序在 hex 文件更新时 （例如重新编译了固件时）自
动导入 hex 文件，并将它写入连接的器件。

要使用该功能，单击 Auto Import Hex + Write Device。这将打开 Import Hex file 对话
框，默认选择为“File”菜单下文件历史记录中的第一个 hex 文件。选择文件后，它会
被写入器件中。现在 PICkit 2 编程器应用程序会监视选定的 hex 文件有无更新。该文件
更新时 （有更新的时间戳），应用程序会自动重新导入 hex 文件，并写入目标器件。

该功能使能时，其他编程操作被禁止。Auto Import Hex + Write Device 按钮在该功能
激活时会保持按下状态。要停止使用该功能，再次单击 Auto Import Hex + Write
Device。
如果导入 hex 文件或器件编程期间遇到错误，则应用程序会自动退出该功能模式。

2.12.2 Read Device + Export Hex File 按钮

单击该按钮时会读目标器件，并打开 Export Hex File 对话框。

2.13 PICKIT 2 校准和设备 ID
可以对 PICkit 2 VDD 进行校准，以应对设备硬件和它所连接的端口的 USB 电压的差异。
此外，还可以为 PICkit 2 设备指定一个设备 ID 字符串，用于唯一识别。

2.13.1 校准 PICkit 2 VDD

校准使得由 PICkit 2 为目标器件提供的 VDD 电压以及在已供电目标器件上检测到并用
软件中报告的电压都更加精确。校准数据存储在 PICkit 2 设备的非易失性存储器中，所
以即使是从 MPLAB IDE 中使用时，设备也可以保持校准状态。

但有一点非常重要，因为校准依赖于 USB 电压，所以将 PICkit 2 设备移到不同的 USB
端口、移到 USB 集线器或从 USB 集线器移走，或者移到另一个计算机端口，都可能使
校准失效。

要校准 PICkit 2 设备，需要一个万用表，或其他可以精确测量电压的方法。将 PICkit 2 设
备从目标板断开，并选择 Tools>Calibrate Vdd & Set Unit ID… 打开校准向导。按照向导
中的步骤完成校准过程。

注： 即使在校准后， PICkit 2 VDD 电压也会受到可用 USB 端口电压的限制。
PICkit 2 提供的 VDD 电压不会大于 USB 端口电压与肖特基二极管电压降的
差值。该电压最低可以为 4.2V，特别是对于笔记本电脑的端口。
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2.13.2 PICkit 2 设备 ID
在校准过程中，可以选择为 PICkit 2 指定一个设备 ID 字符串，以唯一地识别它。

指定之后， PICkit 2 设备 ID 将显示在 PICkit 2 编程器软件标题栏中，并且首次连接到
PICkit 2 时，还会显示在状态窗口中。图 2-19 中显示了一个示例，其中的设备 ID 为
“Lab B-1”。

首次选择 PICkit 2 作为编程器或调试器时，设备 ID 还会显示在 MPLAB IDE 的 Output
窗口中。

图 2-19： 设备 ID
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第 3 章  使用在线串行编程（ICSP™）
3.1 简介

PICkit 2 开发编程器 / 调试器可以对安装在应用电路中的单片机进行在线串行编程
（ICSP）。 ICSP 需要五个信号：

• VPP——编程电压；施加此电压时，器件进入编程模式。

• ICSPCLK/PGC——编程时钟；编程器到目标器件的单向同步串行时钟线。

• ICSPDAT/PGD——编程数据；双向同步串行数据线。

• VDD——电源正电压。

• VSS——电源参考地。

但是，必须将应用电路设计为允许所有编程信号连接至器件，而不会干扰编程信号。
图 3-1 显示了一个典型电路，设计 ICSP 应用电路时，可以此电路为起点。要成功实
现 ICSP 编程，必须遵守以下各节中的注意事项。

图 3-1： 典型的 ICSP™ 应用电路

注： 要详细了解如何对具体器件进行编程，请参见 Microchip 网站
www.microchip.com 提供的器件编程规范。

  1
  2
  3
  4
  5
  6

VPP/MCLR
VDD
VSS
ICSPDAT/PGD
ICSPCLK/PGC
AUX

目标单片机器件

470Ω*

0.1 µF*

  1
  2
  3
  4

VDD
RA5

VSS

RA4
RA3/MCLR/VPP

  8
  7
  6
  5

PICkit™ 2

+5V

或

+5V

至应用

电路

隔离电路：

电阻或肖特基二极管

编程
插头

10k*

*  典型值

RA0/ICSPDAT
RA1/ICSPCLK

RA2
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3.2 隔离 VPP/MCLR/ 端口引脚

施加 VPP 电压时，应用电路设计需要考虑到典型 VPP 电压为 +12V。在下列情况下，这
可能是需要考虑的问题：

将 VPP 引脚用作 MCLR 引脚时

根据器件数据手册的建议，应用电路一般与一个上拉电阻 / 电容电路连接。注意不要使
VPP 电压的变化率变慢，而使其超出编程规范中规定的上升时间 （通常为 1 µs）。

如果在 MCLR 引脚连接监控电路或按钮，建议使用肖特基二极管或限流电阻将它们与
VPP 电压隔离，如图 3-1 所示。关于配合 ICSP 使用监控电路的更多信息，请参见应用
笔记 AN820 “System Supervisors in ICSP™ Architectures”（DS00820）。

将 VPP 引脚用作 I/O 端口引脚时

连接到 I/O 引脚的应用电路可能无法处理 +12V 电压。建议如图 3-1 所示使用肖特基二
极管或限流电阻来隔离电路。

3.3 隔离 ICSPCLK/PGC 和 ICSPDAT/PGD 引脚

必须将 ICSPCLK/PGC 和 ICSPDAT/PGD 引脚与应用电路隔离，以防止应用电路影响编程
信号。 ICSPCLK/PGC 是编程器到目标器件的单向同步串行编程时钟线。 ICSPDAT/PGD
是双向同步串行编程数据线。

如果设计允许，请将这些引脚专用于 ICSP。但是，如果应用电路需要使用这些引脚，
就请采用不会改变信号电平和电压变化率的方式来设计电路。根据不同的应用，隔离电
路会有所差异。图 3-1 显示了其中一种隔离电路，它使用串联电阻将 ICSP 信号与应用
电路隔离。
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3.4 VDD

在 ICSP 编程过程中，必须根据器件规范对器件供电。一般情况下，将器件的电源电压
连接到应用电路的电源电压。应用电路可由 PICkit 2 或外部电源供电。在以下三节介绍
的情况中，有一些事项需要注意。

3.4.1 应用电路由 PICkit 2 供电

PICkit 2 的供电电压可设置为器件编程规范允许的最高和最低电压之间，但最低电压不
得低于 +2.5V。对器件编程或打开 VDD 之前一定要将电压框设置为适当的电压。

3.4.2 应用电路由外部电源供电

PICkit 2 可与由 +2.5V 到 +5.0V 外部电源供电的应用电路配合使用。

3.4.3 使用批量擦除时

某些器件使用批量擦除功能来擦除程序存储器、数据 EEPROM 存储器、ID 单元和配置
位。一般情况下，批量擦除功能要求的电源电压 （VDD）为 4.5 到 5.5V （关于器件的
具体要求，请参见器件编程规范）。

如果将应用电路设计为在不同的电源电压范围内工作，则上述电压范围可能会产生问
题。为了批量擦除器件，在保护所有电压敏感电路的同时，应用电路设计还必须考虑到
批量擦除电压要求。

如果应用电路 VDD 低于批量擦除所要求的最小电压，则在尝试擦除器件之前，会显示
一个对话框来警告用户。

警告

USB 端口电流限制设定为 100 mA。如果目标器件和编程器的电流之和超出了此电流

限制，则 USB 端口将关闭。如果目标器件需要更大电流，则可由外部电源供电。

注： 使用编程器对应用电路供电时，消耗的电流应限制为 25 mA。要保证应用电
路不会使 VDD 上升时间长于 500 µs。
 2009 Microchip Technology Inc. DS51553E_CN 第 29 页



PICkit™ 2 用户指南
3.5 VSS

VSS 为电源的参考地，必须与应用电路同电位。

3.6 电缆长度

最大限度缩短 ICSP 信号的传输距离，方法是尽可能使 ICSP 连接器靠近应用电路中的
器件。最大限度缩短 PICkit 2 和应用电路中器件之间的电缆长度。这样做的目的是使
ICSP 信号保持在电平和电压变化率规范的要求之内，从而实现成功编程。

3.7 串行 EEPROM 和 KEELOQ HCS 器件

这些器件的编程信号和连接不同于单片机的编程信号和连接，如第 3.1 节 “简介”和
图 3-1 中所述。关于这些器件的编程信号连接，请参见 PICkit 2 编程器自述文件
（Help>Readme）。

此外，这些器件不能在线编程。如果尝试对串行 EEPROM 器件在线编程，由于与串行
总线上其他器件的冲突，编程可能会失败。
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第 4 章  PICkit 2 Debug Express
4.1 简介

除了PICkit 2编程器应用程序之外，PICkit 2开发编程器 /调试器还可以与MPLAB® IDE
配合使用，它是免费的集成开发环境，可从 Microchip 网站获取。 MPLAB IDE 允许将
PICkit 2 用作在线调试器和编程器 （仅对于一些选定器件）。

在线调试使您可以在器件嵌入目标硬件时运行、检查和修改您的程序。这大大方便了您
同时调试固件和硬件。

特殊的 PICkit 2 Debug Express 软件与 MPLAB IDE 应用程序相互作用，可运行、停止
和单步运行程序。可设置一个或多个断点，也可以将处理器复位。处理器停止后，可检
查和修改寄存器的内容。

关于如何使用 MPLAB IDE 的更多信息，请参考以下文档：

• MPLAB® IDE 用户指南 （DS51519A_CN）

• MPLAB® IDE 快速入门指南 （DS51281G_CN）

• MPLAB® IDE 在线帮助

4.2 PICkit 2 DEBUG EXPRESS 工具包内容

PICkit 2 Debug Express 工具包 （DV164121）包含以下组件：

1. PICkit 2 开发编程器 / 调试器

2. USB 电缆

3. 带器件的 44 引脚演示板 *
4. PICkit 2 Starter Kit 和 MPLAB IDE CD-ROM
* 以下电路板也可用于调试：

- 要使用Starter Kit附带的低引脚数演示板，将需要AC162061 ICD转接头和AC164110
适配器。

- 要使用 Explorer 16 电路板，需要注意标有“PICKIT2”的连接器会错误显示 PICkit 2
引脚 1 在丝印层中的位置。即，引脚 1 实际上是引脚 6。
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4.3 安装硬件和软件

按照第 2.2 节 “安装 PICkit 2 硬件”中的说明安装 PICkit 2 硬件。

从 Microchip 网站或工具包随附的 CD-ROM 中获取 MPLAB IDE 软件应用程序的副本，
并按照说明安装它。

4.4 使用 PICKIT 2 DEBUG EXPRESS

4.4.1 确定器件支持

PICkit 2 Debug Express当前支持的器件列表，请参见MPLAB IDE安装目录的Readmes
子目录中的 “Readme for PICkit 2.htm”文件。

按照第 4.5 节“Debug Express 教程”中的说明选择器件时，图 4-11 中显示的“Select
Device”（选择器件）对话框会显示 Debug Express 对于选定器件的支持级别。在对话
框的 “Debuggers”（调试器）区域中，“PICkit 2”旁圆圈的颜色指示支持级别：

红色——PICkit 2 Debug Express 当前不支持该器件

黄色——PICkit 2 Debug Express 对该器件提供 beta 支持

绿色——PICkit 2 Debug Express 完全支持该器件

beta 支持表示该器件受支持，但 Microchip 尚未对其进行内部认证测试。

4.4.2 保留的资源

由于 ICD器件的内置在线调试功能和调试器提供的 ICSP功能，PICkit 2 Debug Express
会在调试时使用一些片上资源。它还会在调试期间使用目标器件中的程序存储器和文件
寄存器单元。用户代码不能使用这些存储单元。在 MPLAB IDE 中，寄存器显示中标有
“R”的寄存器代表保留的寄存器。

关于在线调试需要的器件资源的信息，请参见 MPLAB ICD 2 帮助，可通过 MPLAB IDE
中的 Help>Topics 访问。“Resources Used By MPLAB ICD 2”下的器件保留资源信息
与 PICkit 2 Debug Express 的器件保留资源信息相同。

4.4.3 使用 ICD 转接头

对于所有低档 PIC 单片机和部分中档 PIC 单片机，需要在调试转接头电路板上安装特
殊的 –ICD 器件，以支持调试功能。关于这些器件和所需 ICD 转接头电路板部件编号
的列表，请参见 “Header Board Specification”（DS51292） 。“Header Board
Specification”包含在 PICkit 2 CD-ROM 中，也可从 www.microchip.com 在线获取。

注： Debug Express 要求在 ICSPCLK 和 ICSPDAT 引脚上接 4.7 kΩ 的下拉电
阻。较新的配有红色按钮的 PICkit 2 设备内置了下拉电阻。较早的配有黑色
按钮的 PICkit 2 设备需要在目标板上添加下拉电阻。

注： Debug Express 需要 MPLAB IDE 7.50 版或更高版本。
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每个 ICD 转接头板都随附了必需的 –ICD 器件，用于在目标板上使用而不是作为生产时
使用的单片机。不过，大多数转接头板都具有 RJ-11 调试连接器，需要使用 AC164110
RJ-11－ ICSP适配器工具包将该连接器连接到PICkit 2。图 4-1显示了对于PIC16F690
单片机，使用了 AC162061 ICD 转接头、AC164110 适配器工具包和低引脚数演示板。

图 4-1： 使用 PIC16F690 ICD 转接头板

许多中档 PIC 单片机、以及所有 PIC18 和 16 位 PIC 单片机不需要 ICD 转接头，可以
通过 ICSP 编程连接直接调试。包含在 44 引脚演示板上的 PIC16F887 就是如此，只需
将演示板连接到 PICkit 2 就可以对它进行调试 （如图 4-2 所示）。

图 4-2： 将演示板连接到 PICKIT™ 2

AC164110 ICSP™ RJ-11 ICD

ICSP RJ-11 PICkit™ 2 

ICD PIC16F690 AC162061 ICD

DM164120-1

 ICD  PIC®

ICSP™

 PIC16F887 DM164120-2 44
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4.4.4 配置位和 Debug Express
不需要 ICD 转接头、可直接调试的 PIC 单片机在配置字中含有一个 DEBUG 位，该位
用于使能和禁止 PIC 单片机的调试模式。

使用 PICkit 2 Debug Express 时，MPLAB IDE 会自动适当地设置该位，所以不应在源
代码配置设置中指定该位。

许多 16 位 PIC 单片机 （例如 PIC24 和 dsPIC33 系列）具有多个 ICSP 编程和调试端
口引脚，标记为 PGC1/EMUC1 和 PGD1/EMUD1、 PGC2/EMUC2 和 PGD2/EMUD2
等。虽然可以使用任意的 ICSP 端口进行编程，但对于调试，每次只有一个端口处于有
效状态。处于有效状态的 EMU 端口在器件配置位中设置。如果设置的有效端口与 PICkit 2
所连接的 EMU 端口不匹配，器件将无法进入调试模式。在 MPLAB IDE Configuration
Bits 对话框中，这些位通常称为 “Comm Channel Select”位。

4.4.5 Debug Express 断点

PICkit 2 Debug Express 支持的有效断点数取决于目标器件。大多数中、低档器件支持
1 个断点，某些 PIC18 和 16 位器件支持多个断点。

在 MPLAB IDE 中，当前器件可用的有效断点数可以通过选择 Debugger>Breakpoints...
查看。这会打开一个对话框 （图 4-3） ，显示当前在程序存储器中设置的所有断点。
“Active Breakpoint Limit:”（有效断点限制）文本框会显示当前器件总共有多少个断点
可用。“Available Breakpoints:”（可用断点数）文本框会显示当前有多少个断点未用。

图 4-3： PIC16F887 的断点对话框

一些 PIC18 和 16 位器件还支持高级断点。高级断点允许在文件寄存器存储器中设置断
点，并在读取或写入特定文件寄存器时暂停执行。这种断点也可以设置为这种形式：仅
当从某个寄存器中读取或向该寄存器中写入特定值时，才暂停执行。此外，还可以对任
意断点类型设置“Pass Count”（通过计数）。通过计数是在暂停执行之前满足断点条

警告

在正常情况下，不应在源代码配置设置中指定 DEBUG 配置位的值。如果这样做，可能导致在

脱离调试器对器件进行编程时，该位被置为有效。这会导致该器件在应用电路中无法正常工作，
或者根本不工作。
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件的次数。例如，将某个程序存储器断点的通过计数设置为 “2”时，表示指令将执行
两次而不停止，第三次执行指令后，断点将暂停代码执行。所有断点的默认通过计数都
为 “0”，表示在第一次遇到断点时就暂停执行。

如果当前器件支持高级断点，将可以使用 MPLAB IDE 菜单选项 Debugger>Advanced
Breakpoints...，打开高级断点对话框。如果当前器件不支持高级断点，该菜单选项将灰
掉或缺失。使用 “Break Point #”组合框来选择要编辑的断点。

图 4-4： ADVANCED BREAKPOINTS 对话框

4.4.6 断点滑动

对于 PIC 单片机的在线调试实现，代码会在断点处指令之后的指令处暂停执行。这意味
着在调试器暂停时，断点处指令已经执行。这称为 “断点滑动”。

所以，需要知道一些断点行为。当在 GOTO、 CALL 或 RETURN 指令上设置断点时，调
试器将在目标指令处暂停，因为在暂停之前会执行设有断点的程序跳转指令。此外，当
使用调试器的单步跳过 （Step Over）功能时，如果存在断点，断点将设置在调试器
“单步跳过”的 CALL指令之后的指令处。如果 CALL指令后紧随着另一条 CALL指令，
那么将导致调试器在第二条 CALL 指令的目标处暂停。为防止这种情况，可以在两条
CALL指令之间放入一条 NOP指令。
请注意， 16 位器件将在断点指令之后的第二条指令处暂停。

注： Advanced Breakpoint 对话框将显示已在程序存储器中设置的所有断点。不
过，该对话框不能用于在程序存储器中设置或清除断点，或者编辑现有程序
存储器断点的地址。在 Advanced Breakpoint 对话框中，只能编辑程序存储
器断点的 Pass Count 值。要编辑、设置或清除程序存储器断点，请使用
MPLAB IDE 编辑器或 Debugger>Breakpoints... 菜单对话框。
 2009 Microchip Technology Inc. DS51553E_CN 第 35 页



PICkit™ 2 用户指南
4.4.7 链接描述文件

如果项目使用了链接描述文件，那么在调试时必须使用特殊的 ICD 链接描述文件，它们
会保留由 PICkit 2 Debug Express 使用的资源。每种器件具有单独的调试链接描述文
件，文件名会在器件名称末尾包含一个 “i”。

例如：

16F877i.lkr——PIC16F877 器件的在线调试链接描述文件

18F4520i.lkr——PIC18F4520 器件的在线调试链接描述文件

使用 PICkit 2 Debug Express 进行调试时，应使用 ICD 链接描述文件，而不是标准链
接描述文件。

4.5 DEBUG EXPRESS 教程

本教程旨在用于 PICkit 2 44 引脚演示板和 PIC16F887 单片机。该演示板随 PICkit 2
Debug Express 工具包一起提供，也可单独提供 （部件编号为 DM164120-2）。

如果无法获得该演示板，仍然建议详细阅读本教程，了解如何在 MPLAB IDE 中将 PICkit 2
用作调试器。

用于本教程的源文件随 PICkit 2 编程器软件一起安装。

4.5.1 选择器件

在 MPLAB IDE 中选择器件：

1. 启动 MPLAB IDE 应用程序。

2. 从 MPLAB IDE 菜单栏中，选择 Configure>Select Device （图 4-5）。

图 4-5： MPLAB® IDE 菜单栏
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3. 在 Select Device 对话框（图 4-6）中，单击“Device”下拉列表，并选择器件。
在本教程中，需要选择 PIC16F887 器件。

图 4-6： SELECT DEVICE 对话框

4. 此对话框中无需做其他更改。单击 OK （确定）。

4.5.2 选择 PICkit 2 作为调试工具

1. 选择 Debugger>Select Tool>PICkit 2。 MPLAB IDE 将会增加 PICkit 2 调试功能
（图 4-7）：(A) 状态条会将 PICkit 2 显示为调试工具，(B) 将增加 PICkit 2 调试工
具栏，(C) Debugger菜单将增加PICkit 2调试功能，(D) Output窗口将在PICkit 2
选项卡中显示 PICkit 2 和目标板之间的通信状态。

图 4-7： PICkit™ 2 调试工具

A

C

D

B
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2. 选择 Debugger>Settings 设置 PICkit 2 操作。单击 “Connect on Startup”（启
动时连接）复选框使能自动连接功能 （图 4-8）。单击 OK。

图 4-8： PICkit™ 2 SETTINGS 对话框

3. 如果在选择PICkit 2作为调试工具时，它未自动连接，则选择Debugger>Connect
现在进行连接。Output 窗口中将会显示连接状态。根据 MPLAB IDE 软件的版本
或选定器件，可能会显示一条消息，指出固件 （PICkit 2 操作系统）需要更新。
MPLAB IDE 会自动安装新的固件。

4.5.3 创建 MPLAB IDE 项目

MPLAB IDE 项目和工作区将开发项目的所有文件和设置保存在一起。 Project Wizard
（项目向导）会帮助您设置新项目。

1. 选择Project>Project Wizard设置项目。将显示Project Wizard的欢迎屏幕（图4-9）。
单击 Next （下一步）继续第一步。

图 4-9： 项目向导——欢迎
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2. 从 “Device”下拉框中选择 PIC16F887 器件（如果尚未选择它，图 4-10）。单
击 Next 继续第二步。

图 4-10： 第一步——选择器件

3. 对于该项目，将使用 MPASM™ 汇编器工具。从 Active Toolsuite（有效工具包）
下拉菜单中选择 “Microchip MPASM Toolsuite”（图 4-11）。

确保工具设置为正确的可执行文件，默认在
C:\Program Files\Microchip\MPASM Suite文件夹中，如下：

- MPASM 汇编器应指向 mpasmwin.exe。
- MPLINK™ 目标链接器应指向 mplink.exe。
- MPLIB™ 目标库管理器应指向 mplib.exe。
单击 Next 继续第三步。

图 4-11： 第二步——选择语言工具套件
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4. 单击 Browse（图 4-12）进行查找，或创建新的项目目录和项目名称。对于本教
程，请选择位置
C:\Program Files\Microchip\PICkit 2 v2\DBE Demo，并为项目文件
命名，例如 “PIC16F887 Debug Demo”。

图 4-12： 第三步——创建新项目

5. 添加项目源文件 （图 4-13）。从左边窗格中转到
C:\Program Files\Microchip\PICkit 2 v2\DBE Demo。选择并高亮显
示 16F887Demo.asm文件，然后单击 Add（添加）按钮。该文件将被放入右边
窗格中。

“A”允许 MPLAB IDE 决定对于项目，文件路径是绝对路径还是相对路径。关于
其他可能的文件添加模式的说明，以及如何更改为其他模式的信息，请参见
MPLAB IDE 文档。不要更改该项目的设置。单击 Next 继续，转到 Summary（摘
要）窗口。

注： 其他文件可以稍后添加。

注： 对于包含多个汇编文件的项目（例如，多文件项目和 C 代码项目），还
需要添加链接描述文件。更多详细信息，请参见语言工具文档。
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图 4-13： 第四步——添加文件

6. 如果发生任何错误，单击 Back （上一步）按钮可返回到 Project Wizard 中以前
的任何一个步骤。否则，单击 Finish （完成）。 

图 4-14： 项目向导——摘要

4.5.4 查看演示项目

完成项目设置并退出 Project Wizard 后，将在 MPLAB IDE 桌面窗口中显示项目窗口
（图 4-15）。如果尚未打开，请选择 View>Project 打开它。

如果需要，可以用项目窗口向项目添加或删除文件。在项目窗口树中右键单击文件，显
示带有选项 （包括添加或删除文件）的菜单。
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图 4-15： 项目窗口文件菜单

4.5.5 创建 Hex 文件

要创建用于器件编程的 hex 文件，需要编译项目。选择 Project>Build All，或右键单击
项目窗口中的项目名称，然后从弹出菜单中选择“Build All”（编译全部）。MPASM 汇
编器将生成文件名和 .asm 源文件名相同的 hex 文件。汇编器的进度将显示在 Output
窗口的 Build 选项卡中 （图 4-16）。

图 4-16： OUTPUT 窗口——编译项目

4.5.6 检查配置位的值

将烧写到器件中的配置位在程序中使用 __CONFIG伪指令设置。编译项目之后，这些位
的值可以使用 Configuration Bits 窗口进行验证。选择 Configure>Configuration Bits 打
开该窗口 （图 4-17）。

对于本教程，现在必须如下设置配置位：

Config1：
• Oscillator – Internal RC No Clock （振荡器——内部 RC，无时钟）

• Watchdog Timer – Off （看门狗定时器——关）

• Power-Up Timer – On （上电延时定时器——开）

• Master Clear Enable – MCLR is external（主复位使能——MCLR 是外部复位输入
引脚） 

• Code-Protect – Off （代码保护——关）

• Data EE Protect – Off （数据 EE 保护——关）

• Brown-Out Detect – BOD and SBOREN Disabled（欠压检测——BOD和SBOREN
被禁止）

• Internal-External Switch Over Mode – Disabled （内 / 外部切换模式——禁止）

• Monitor Clock Fail-safe – Disabled （故障保护时钟监视器——禁止）

• Low-Voltage Program – Disabled （低电压编程——禁止）
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Config 2：
• Self Write Enable – No Protection （自写使能——无保护）

• Master Brown-out Reset Sel Bit – Brown-out at 2.1V（主欠压复位选择位——2.1V
欠压复位）

图 4-17： 配置位设置

4.5.7 载入程序代码进行调试

要烧写器件，请选择 Debugger>Program 将 16F887Demo.hex文件烧写到 44 引脚演
示板上的 PIC16F887 中。

烧写只需几秒钟。烧写期间， Output 对话框窗口的 PICkit 2 选项卡将显示操作的当前
进度。烧写完成后，对话框看上去就像图 4-18。

图 4-18： OUTPUT 窗口——烧写器件以进行调试

注： 当选择 PICkit 2 作为调试器时，调试执行程序代码自动烧写到 PIC16F887
（目标器件）程序存储器的高地址区。必须将调试代码烧写到目标器件，才
能使用 PICkit 2 的在线调试功能。
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4.5.8 运行 PIC16F887 调试演示

PICkit 2 Debug Express 可以用实时（Run）或单步（Step Into、Step Over、Step Out
和 Animate）方式执行程序代码。在 MPLAB IDE 中选择 Run 时，将实时执行代码。当
程序暂停时 （通过 Halt 或断点），可以单步执行代码。

以下工具栏按钮可用于快速访问常用调试操作：

要运行演示代码：

1. 在项目窗口中双击 16F887Demo.asm 文件，或从工具栏菜单选择 File>Open。
代码将显示在文件窗口中。

2. 选择 Debugger>Run，或单击 Run 按钮。

3. 旋转位于演示板上的电位器 （RP1），观察 LED。

如果程序运行正常，LED 会根据电位器旋转方向闪烁得更快或更慢。但是，为了演示调
试，故意在代码中加入了一个错误。关于调试的说明，请参见第 4.5.9 节 “调试
PIC16F887 调试演示代码”。

4. 选择 Debugger>Halt，或单击 Halt 按钮可停止程序的执行。在文件窗口中，会有
一个绿色实线箭头标记程序暂停时所处的代码行。

5. 选择 Debugger>Reset>Processor Reset 将程序复位。箭头将会消失，表示器件
已复位。

4.5.9 调试 PIC16F887 调试演示代码

以下任何问题都可能使 PIC16F887 调试演示程序无法正常运行： 
1. A/D 转换器值未正确写入延时子程序。

2. A/D 转换器未使能，或者未设置为进行转换。

3. 源代码中的输入错误使程序运行不正确。

要找出上述第一种可能发生的问题，可在将 A/D 结果值写入延时高字节的代码行设置断
点：

1. 将光标置于 16F887Demo.asm文件中的以下代码行： 
movwf Delay+1，如图 4-19 所示。
程序会在完成 A/D 转换后停在该断点处。

2. 右键单击代码行来显示下拉菜单，并选择“Set Breakpoint”，或者双击代码行。
在代码行旁边将出现一个断点符号 （一个实心红色八边形中包含一个字母 B），
如图 4-19 所示。 

调试器菜单 工具栏按钮

Run （运行）

Halt （暂停）

Animate （连续单步运行）

Step Into （单步运行）

Step Over （单步跳过）

Step Out （单步跳出）

Reset （复位）
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图 4-19： 设置断点

3. 选择 Debugger>Run，或单击 Run 运行程序。程序执行到标记为断点的那行时，
断点会停止程序的执行。

4. 将鼠标移到断点上方的代码行中的 ADRESH 上，将会显示该文件寄存器的值
（图 4-20）。

图 4-20： ADRESH 寄存器的值

5. 调节电位器 （RP1），选择 Debug>Run 继续运行程序。程序会运行循环，然后
再次暂停。

6. 再次将鼠标移到 ADRESH 上，发现 A/D 结果未变。这样看来 A/D 转换未起作用。
A/D 转换的初始化和设置发生在程序开始时。

7. 选择 Debugger>Reset 将程序复位。

8. 选择 View>Watch 打开新的 Watch （观察）窗口。用户可通过该窗口观察程序
执行时 A/D 寄存器值的变化。Watch对话框打开时选中了 Watch 1 选项卡，如
图 4-21 所示。

注： 根据器件，断点暂停位置可能会 “滑动”超过断点位置。这种情况下，
程序将在以下代码行处暂停：
incfsz    Delay,f
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图 4-21： 新的 WATCH 窗口

9. 从第一个下拉列表中选择 ADCON0，然后单击 Add SFR 将 ADCON0 添加到
Watch 窗口中。重复这一步将 ADCON1 和 ADRESH 添加到 Watch 窗口。选定
的 SFR 应在 Watch 窗口中可见，如图 4-22 所示。

图 4-22： 添加要监视的 SFR

10. 选择 Debugger>Run 运行程序。同样，程序将在到达断点后停止。

11. 在Watch窗口中检查ADCON0和ADCON1寄存器的值。ADCON0的值是“0x40”
（b’01000000’）。这对应于程序中指定的十六进制值。但是，这是不对的。回
顾《PIC16F882/883/884/886/887 数据手册》（DS41291D_CN）的“模数（A/D）
转换器模块”一章，指出要启动 A/D 模块，最后一位应该是 1（b’01000001’）。
要解决这个问题，可将：
movlw 0x40
改为
movlw 0x41，如图 4-23 所示。

注： 使用 PICkit 2 Debug Express 进行调试时，建议不要使用 View>File Registers
和 View>Special Function Registers 窗口。如果打开这两个窗口，则对于每
个操作，都必须写入全部内容，然后再从目标器件读取全部内容。这会显著
降低调试操作的速度。应根据本教程中的说明，仅将感兴趣的 SFR 和文件
寄存器变量添加到 Watch 窗口中。
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图 4-23： A/D 模块代码

12. 选择 File>Save 保存更改。

13. 您必须重新编译项目，并重新烧写器件，以使更改生效。选择 Project>Build All
重新编译项目，然后选择 Debugger>Program 使用 PICkit 2 重新烧写器件。

14. 选择 Debugger>Run 运行程序。同样，程序将在到达断点后停止。

15. 在 Watch 窗口中检查值。此时， ADCON0 应为 0x41 （图 4-24）。

图 4-24： ADCON 正确值

16. 右键单击断点所标记的代码行，并选择 Remove>Breakpoint，或者双击代码行来
去除断点。

17. 选择 Debugger>Run 实时运行程序。旋转电位器（RP1）更改 LED 上显示的值。
现在，它可以正确工作！

本教程中的源代码只包含一个错误。但是，实际代码可能会有更多错误。使用 MPLAB
IDE 和 PICkit 2 调试功能，您可以顺利地找到并修复代码中的问题。
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4.5.10 烧写调试好的应用程序

程序成功调试并运行后，下一步就是烧写器件使之在完成的设计中独立工作。此时，为
ICD 保留的资源会被释放出来供应用程序使用。要烧写应用程序，请执行以下步骤： 
1. 选择 Debugger>Select Tool>None，禁止将 PICkit 2 用作调试工具。

2. 在 Programmer>Select Programmer 菜单中选择 PICkit 2 作为编程器。

3. 可选：在 Configure>ID Memory 中设置 ID （图 4-25）。

图 4-25： USER ID MEMORY

4. 在 Programmer>Settings 的 Program 选项卡中设置编程参数。

5. 选择 Programmer>Program。

现在，目标器件将独立运行。
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第 5 章  疑难解答
5.1 简介

本章列出了与使用 PICkit 2 开发编程器 / 调试器相关的常见问题及其解答。此外，还提
供了有关 PICkit 2 Debug Express MPLAB IDE 错误的信息。

• 常见问题

• PICkit 2 Debug Express MPLAB IDE 错误

5.2 常见问题

• 未识别到器件

• 电流超出限制

• Microsoft Windows 驱动程序

• 校验和读取时返回的内容为全零

• Microsoft Windows 95/98/NT
• VDD/VPP 错误

• 编程错误

• Windows 错误：无法识别的 USB 设备

• PICkit 2 未找到

• PICkit 2 编程器应用程序锁定

• 低引脚数演示板按钮不起作用

• 使用演示板课程

• 由于配置而编程失败

• 无法对 PIC10F 器件编程

• PICkit 2 AUX 引脚

• PICkit 2 HEX 文件格式

• 窗口显示问题

• 存储单元标记为 “RR”

• Debug Express 很慢

• Debug Express 超出断点位置

未识别到器件

问题

为什么会接收到“No Device Found”消息？

回答

请验证是否支持该器件，并且目标 MCU 是否已根据第 3 章“使用在线串行编程
（ICSP™）”的说明连接至 PICkit 2。根据器件数据手册，确认 PIC18FXXJXX、PIC24X
和 dsPIC33F 器件在 VDDCORE/VCAP 引脚上接有适当的电容。

验证该器件是否属于状态窗口顶部显示的当前选中系列的成员。从 Device Family 菜单
中选择正确的系列（如果需要）。

另请参见由于配置而编程失败主题。
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电流超出限制

问题

为什么会在 Microsoft® Windows® 程序中接收到错误消息“USB Hub Current Limit
Exceeded”？

回答

检查应用电路从 PICkit 2 汲取的电流是否超过 25 mA。

Microsoft Windows 驱动程序

问题

将PICkit 2设备插到USB端口后，Windows 98 SE请求提供驱动程序。驱动程序在哪里？

回答

PICkit 2 使用 Windows 98 SE 随附的驱动程序。当 Windows 98 SE 提示提供驱动程序
时，请选择“搜索设备的最佳驱动程序”，然后选择“Microsoft Windows Update”旁
边的复选框并单击下一步。 Windows 操作系统将自动安装相应的驱动程序。请勿使用
Microchip 的 MPLAB ICD 2 USB 设备驱动程序。

校验和读取时返回的内容为全零

问题

单击 Verify 或 Read 按钮时， Program Memory 窗口显示的为全零。问题出在哪里？

回答

器件可能被代码保护了。请确保在 Configuration Word 中没有选择代码保护。

Microsoft Windows 95/98/NT

问题

是否可以在 Windows 95/98/NT 上运行？

回答

不可以。这些操作系统或者不支持 USB，或者驱动程序不兼容。

VDD/VPP 错误

问题

为什么我总是收到“VDD Error”或“VPP Error”？

回答

该错误表示 PICkit 2 无法将 VDD 或 VPP 驱动至目标电压。请检查电路板上有无短路或
很大的电流消耗，并确认是否按照第 3 章 “使用在线串行编程 （ICSP™）”中所述将
目标器件连接到 PICkit 2。确保 VDD 电容不会使 VDD 上升时间长于 500 µs。
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编程错误

问题

为什么我只能对部分器件编程？

回答

如果某些器件配置为低电压编程，则悬空的 PGM 引脚会妨碍编程。编程时，可用电阻
将该引脚拉为低电平。

部分中档器件，如 PIC16F72/73/74/76/77 系列和 PIC16F737/747/767/777 系列有一个
+4.75V 的最低编程 VDD 要求。根据 USB 电压，PICkit 2 可能无法在 VDD 上提供 +4.75V
电压。可用外部的 +5.0V 电源对这些器件编程。

部分 PIC18F 器件要求 VDD 上有较大的旁路电容。试将总旁路电容增加到 10 uF。
PIC18FXXJXX、PIC24X 和 dsPIC30F/33F 器件要求 VDDCORE/VCAP 引脚上有 4.7 uF 的
电容才能正常工作。如果未使用独立稳压器提供 VDDCORE，要确保 ENVREG 引脚连接
到 VDD。

Windows 错误：无法识别的 USB 设备

问题

当我将 PICkit 2 插入 USB 时，为什么显示“unrecognized device”错误？

回答

如果在 PICkit 2 连接到目标板时将它插入 USB，则可能会出现该错误。将 PICkit 2 插入
PC 时，以及重启或启动 PC 时，请确保 PICkit 2 未连接到目标器件。

PICkit 2 与某些 USB 集线器配合使用时，也可能会出现该错误。如果 PICkit 2 是被插入
一个 USB 集线器端口，可以试一下将 PICkit 2 直接插入 PC 的 USB 端口。

PICkit 2 未找到

问题

我已将PICkit 2插入USB，但PICkit 2编程器应用程序总是显示“PICkit 2 Not Found”？
回答

请参见 Windows 错误：无法识别的 USB 设备的回答。

PICkit 2 编程器应用程序锁定

问题

为什么 PICkit 2 编程器窗口会锁定？

回答

许多时候，软件并未真正锁定。在编程操作期间， PICkit 2 应用程序用户界面会处于不
活动状态。到编程操作完成之前，如果另一个应用程序获得了焦点，或者 PICkit 2 只是
刚刚重新获得焦点，Windows 操作系统可能会停止更新 PICkit 2。编程操作完成时，应
用程序窗口将会更新。对于存储器很大的器件，编程操作可能需要几分钟的时间。对于
8 位器件，在确定软件真正锁定之前，先试着等待至少 2 分钟。对于 16 位器件，请试着
等待 5 分钟，以便操作完成。
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有一些 USB 控制器芯片组似乎会导致 PICkit 2 的锁定问题，这种情况在笔记本电脑中更
为常见。通常，可以通过在 PC 和 PICkit 2 设备之间连接一个 USB 集线器，或使用 USB
Cardbus 适配器来解决这个问题。建议使用带外部电源的 USB 集线器。

低引脚数演示板按钮不起作用

问题

当我运行低引脚数演示板课程时，为什么按钮不起作用？

回答

在 MPLAB IDE 中编程课程代码时， IDE 始终会在 PICkit 2 MCLR-VPP 引脚上维持一个
输出电压。在低引脚数演示板和 28 引脚演示板上，按钮信号与 MCLR 信号连接。PICkit
2 输出会影响按钮信号。

请使用 PICkit 2 编程器软件应用程序来编程和运行低引脚数演示板课程。

此外，在 MPLAB IDE 的将来版本中，可选择在器件“从复位状态释放”时，允许
MCLR-VPP 引脚为三态。选择 Programmer>Settings 可查看该选项。请注意，在调试期
间该选项不适用。

使用演示板课程

问题

所包含的课程位于何处？是否有关于它们的文档？

回答

Starter Kit 和 Debug Express 工具包课程可以从所包含的 PICkit 2 CD-ROM 中安装。课
程将安装到本地硬盘的 C:\Pk2 Lessons\。 
课程项目的文档位于所包含演示板的用户指南中。对于 Starter Kit，请参见《低引脚数
演示板用户指南》（DS51556A_CN）。对于 Debug Express 工具包，请参见“44-Pin
Demo Board User’s Guide”（DS41296）。这两个文档都可以从 PICkit 2 编程器的 Help
菜单中打开。

由于配置而编程失败

问题

为什么对器件进行编程时，总是由于配置字而出现失败，之后 PICkit 2 无法识别器件？

回答

这可能是由影响 ICSP PGD 和 PGC 引脚的配置设置或程序代码导致的。这种影响会阻
止目标 PIC MCU 进入编程模式。

尝试对这些器件进行编程操作时，请选中菜单选项 Tools>Use VPP First Program
Entry。该编程模式入口通常可以解决该问题，但它要求目标器件从 PICkit 2 设备的 VDD
引脚供电。
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无法对 PIC10F 器件编程

问题

为什么无法在低引脚数演示板中对 PIC10F 器件编程？

回答

低引脚数演示板支持 8 引脚器件。 PIC10F 器件是 6 引脚器件，虽然它们可以以 8 引脚
DIP 封装订购。 PIC10F 的引脚排列与低引脚数演示板不兼容。应当使用 AC163020
PIC10F2XX 编程适配器。

PICkit 2 AUX 引脚

问题

AUX 引脚有什么用途？如何连接它？

回答

PICkit 2 AUX 引脚不用于对 PIC 单片机编程，应保持不连接。只有对某些串行 EEPROM
编程时，才使用 AUX 引脚。关于 EEPROM 连接的信息，请参见 PICkit 2 自述文件
（Help>Readme）。

PICkit 2 HEX 文件格式

问题

PICkit 2 编程器应用程序使用的是哪种 HEX 文件格式？

回答

PICkit 2 编程器应用程序使用 Intel Hex 32 格式，该格式通常称为 INHX32。不过，PICkit
2 不支持记录类型 03 和 05。低有效字节位于 hex 文件低地址（小尾数格式）。

窗口显示问题

问题

为什么PICkit 2编程器应用程序将程序存储器和 /或EEPROM数据存储单元全部显示为
句点 “…”？为什么无法关闭 Help>About 对话框？

回答

这些问题通常是由非标准的监视器 DPI 设置导致的。可以通过将 DPI 设置为正常设置
（96 DPI）来修正这一点。要这样做：

1. 请右键单击 Windows 的桌面背景，然后从弹出菜单中选择 “属性”。这会打开
“显示属性”对话框。

2. 在 “显示属性”对话框中，选择设置选项卡。

3. 在该选项卡中，单击高级打开 “监视器”对话框。

4. 在 “监视器”对话框中，选择常规选项卡。

5. 在该选项卡中，将 “DPI 设置”更改为 “正常大小”（96 DPI）。

6. 单击应用，然后单击确定按钮关闭对话框。

7. 单击确定关闭 “显示属性”对话框。

要使更改生效，可能需要重启 PC。
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存储单元标记为 “RR”

问题

为什么在 File Register 窗口或 Program Memory 窗口中，一些存储单元标记有“RR”？

回答

它们是由 ICD 调试器（包括 PICkit 2 Debug Express）在调试期间为调试执行程序保留
的存储单元。请参见第 4.4.2 节“保留的资源”。

Debug Express 很慢

问题

为什么使用 PICkit 2 进行调试这么慢？

回答

在 MPLAB IDE 中打开 View>File Registers 或 View>Special Function Registers 窗口
时，由于通过调试器交换的信息量，调试速度会显著降低。请改为使用 Watch 窗口，如
第 4.5.9 节“调试 PIC16F887 调试演示代码”中所述。

目标器件振荡器的速度也会直接影响调试界面。使用频率低于 1 MHz 的振荡器进行调试
时，可以注意到调试性能下降。

Debug Express 超出断点位置

问题

为什么 PICkit 2 Debug Express 不是停止在断点所在指令处？

回答

这种行为称为“断点滑动”，在第 4.4.6 节“断点滑动”中对它进行了介绍。

5.3 PICKIT 2 DEBUG EXPRESS MPLAB IDE 错误

PK2Error0002:Allocation failure (Component)
PK2Error0003:Missing component (Component)
PK2Error0005:Failed to acquire component (Component, HRESULT)
PK2Error0006:Failed external call (Component, Method, HRESULT)

说明：在内部操作期间，或者与 MPLAB IDE 环境通信时，初始化 PICkit 2 组件时发生
错误。最有可能的原因是安装不完整或已损坏。

建议操作： 
1. 从 PC 中卸载 MPLAB IDE 的所有版本。

2. 重新安装所需的 MPLAB IDE 版本。

3. 如果问题依然存在，请与 Microchip 联系。

PK2Error0008:Read failure (GetLastError)
PK2Error0009:Write failure (GetLastError)

说明：MPLAB IDE 无法与 PICkit 2 通信。可能的原因包括：PICkit 2 未在 USB 上正确
进行枚举、目标板导致 USB 过流条件，或者 USB 集线器存在问题。
DS51553E_CN 第 54 页  2009 Microchip Technology Inc.



疑难解答
建议操作：确保目标板不会从 PICkit 2 汲取超过 25 mA 的电流。如果确实如此，请对目
标板使用外部电源。

目标板可能会干扰 PICkit 2 在 USB 上的枚举。将 PICkit 2 连接到 USB 端口，以及启动
或重启所连接的 PC 时，请确保将 PICkit 2 从目标板断开。

如果 PICkit 2 是被连接到一个 USB 集线器，可以试一下将 PICkit 2 直接连接到 PC 的
USB 端口。

在 MPLAB IDE 中使用 PICkit 2 作为编程器或调试器时，不要同时运行 PICkit 2 编程器
应用程序和 PK2CMD。

如果问题依然存在，请尝试使用 PICkit 2 编程器应用程序来连接 PICkit 2。

PK2Error0010:Failed to unload PICkit 2

说明：当切换到其他工具模式时，MPLAB IDE 无法从作为调试器或编程器的 PICkit 2 断
开。

建议操作：将 PICkit 2 从 USB 断开，重启计算机，然后将 PICkit 2 重新连接到 USB（确
保 PICkit 2 未连接到目标板）。如果问题依然存在，请与 Microchip 联系。

PK2Error0011:PICkit 2 is already busy.Unable to perform requested task.

说明：在 PICkit 2 Debug Express 忙于为前一个请求服务时，被请求执行一个操作。例
如，在尝试请求单步调试操作时，可能仍在处理某个编程操作。

建议操作：通常情况下不会发生这种情况，因为在 PICkit 2 为请求提供服务时，用户界
面会被禁止。请等待原先的操作完成。

PK2Error0012:Unable to open file (Filename)

说明：PICkit 2 Debug Express 无法打开指定的文件。 
建议操作：确保文件存在，并且文件或目录许可权允许对该文件进行访问。安装不完整
或损坏也可能导致这个问题。请参见 PK2Error0002 的建议操作。

PK2Error0013:Bad hex line (File - Line)
PK2Error0014:Invalid address in hex file (File - Line - Address)

说明：PICkit 2 Debug Express 在调试执行 hex 文件中检测到错误。 
建议操作：因为所有调试执行程序 hex 文件都是由 Microchip 提供的，所以最有可能的
原因是安装已损坏。请参见 PK2Error0002 的建议操作。

PK2Error0015:Failed Windows call (WinFunc - GetLastError)

说明：PICkit 2 Debug Express 中对某个 Windows 函数的调用失败。这是一个内部错
误，主要用于调试目的。

建议操作：这可能由于系统资源不足或安装已损坏导致的。

1. 请尝试重启系统来释放存储器。

2. 请确保硬盘中具有合理的可用空间，并且硬盘碎片不会过多。

3. 对于损坏的安装，请参见 PK2Error0002 的建议操作。
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PK2Error0016:Failed to find firmware files (MPLABDir)

说明：PICkit 2 Debug Express 无法找到 PICkit 2 操作系统固件文件。 
建议操作：这可能是由于安装不完整或已损坏导致的。请参见 PK2Error0002 的建议
操作。

PK2Error0017:Invalid hex file (Filename - Start - End)

说明：PICkit 2 Debug Express 在 PICkit 2 操作系统 hex 文件中检测到错误。 
建议操作：因为所有操作系统 hex 文件都是由 Microchip 提供的，所以最有可能的原因
是安装已损坏。请参见 PK2Error0002 的建议操作。

PK2Error0018:Unable to enter bootloader

说明：更新 PICkit 2 操作系统时， PICkit 2 Debug Express 无法访问 PICkit 2 设备的自
举程序。

建议操作：将 PICkit 2 设备从 USB 和目标板断开。在按下 PICkit 2 设备按钮的同时，将
PICkit 2 设备插回 USB 端口中。BUSY LED 将会缓慢闪烁。如果不闪烁，则自举程序可
能已损坏。就该问题联系 Microchip。

PK2Error0019:Failed PICkit OS read ([1] - [2] - [3] - [4])

说明：与 PICkit 2 自举程序通信时发生错误。 
建议操作：将 PICkit 2 设备从 USB 和目标板上取下，重启 PC，将 PICkit 2 设备重新连
接到 USB，然后重试操作。如果这样做不起作用，则尝试使用 PICkit 2 编程器应用程序
来更新固件。

PK2Error0020:Failed PICkit OS verify (Address - Read - Expected)

说明：将 PICkit 2 操作系统下载到 PICkit 2 设备时出现失败。 
建议操作：将 PICkit 2 设备从 USB 和目标板上取下，重启 PC，将 PICkit 2 设备重新连
接到 USB，然后重试操作。如果这样做不起作用，则尝试使用 PICkit 2 编程器应用程序
来更新固件。

PK2Error0021:Unable to exit bootloader

说明：将PICkit 2操作系统下载到设备中之后，PICkit 2 Debug Express无法退出PICkit 2
自举程序模式。

建议操作：将 PICkit 2 设备从 USB 和目标板上取下，重启 PC，将 PICkit 2 设备重新连
接到 USB，然后重试操作。如果这样做不起作用，则尝试使用 PICkit 2 编程器应用程序
来更新固件。

PK2Error0022:PICkit 2 not found

说明：MPLAB IDE 无法在任何 USB 端口上检测到 PICkit 2 设备。

建议操作：请参见 PK2Error0008 的建议操作。

PK2Error0023:Target VDD measured at X.XV which is outside the 
operational range of this device (minV - maxV)

说明：目标电源超出 PICkit 2 对于当前器件支持的电压范围。这可能是由于器件批量擦
除限制或 PICkit 2 硬件限制导致的。
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建议操作：使用处于规定范围内的目标 VDD 电压。如果目标 VDD 接近某个限制，但处于
规定限制内，却出现该错误，请尝试使用 PICkit 2 编程器软件来校准 PICkit 2 设备，以
便可以更准确地读取目标电压。

PK2Error0024:PICkit 2 was unable to establish a valid VDD on the target 
(Attempted V - Read V)

说明：PICkit 2无法向目标板提供期望的VDD电压。这通常是由于VDD负载太重导致的。 
建议操作：从外部为目标板供电，和 / 或尝试使用 PICkit 2 编程器软件来校准 PICkit 2
设备。

PK2Error0025:Failed to load PICkit 2

说明：尝试在 MPLAB IDE 中加载时， PICkit 2 Debug Express 遇到严重错误。

建议操作：这可能是由于安装不完整或已损坏导致的。请参见 PK2Error0003 的建议
操作。

PK2Error0027:Failed verify (Address - Expected Value - Value Read)

说明：校验操作失败。错误消息中会指明所涉及的存储器类型和地址，并显示期望值和
实际读取值。对于先前编程并设置代码保护的器件，校验操作会失败，因为读取存储器
内容时，代码保护功能会返回全 0。

建议操作：确保器件不受代码保护。检查 ICSP 连接，如第 3 章“使用在线串行编程
（ICSP™）”中所述。如果目标器件具有 AVDD 和 AVSS 引脚，请检查它们是否正确连
接。根据器件数据手册，确认 PIC18FXXJXX、 PIC24X 和 dsPIC33F 器件在
VDDCORE/VCAP 引脚上接有适当的电容。对于一些 PIC18F 器件， VDD 引脚上可能需要
高达 10 uF 的电容，这样才能正确进行编程。

PK2Error0028:Unable to enter debug mode

说明：PICkit 2 Debug Express 无法连接到目标器件中的调试执行程序。

建议操作：该错误的常见原因有：

1. 如果目标器件是中、低档器件 （PIC10F、 PIC12F 和 PIC16F），可能需要使用
ICD 转接头来进行调试。请参见第 4.4.3 节 “使用 ICD 转接头”。

2. 器件振荡器不工作。检查配置位，并确保器件的振荡器正常工作。

3. 在尝试运行或单步执行代码之前，确保在MPLAB IDE中选择Debugger>Program。

4. 如果具有带黑色按钮的 PICkit 2，则可能需要连接一些下拉电阻，才能可靠地进
行调试。请参见第 4.3 节 “安装硬件和软件”。

5. 目标板未供电或未正确供电。请检查电源。

6. PICkit 2 VDD 输出引脚未连接到目标板。即使目标板自身带有电源，也必须始终
将该引脚连接到目标 VDD 电源。

注： 当从目标器件读取到第一个错误值时， PICkit 2 Debug Express 会终止校验
操作。所以将只会报告这第一个错误值。可能还存在其他错误值。
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7. PICkit 2 设备已从目标板断开，或者一个或多个引脚上的连接断断续续。检查
PICkit 2 到目标板的连接。

8. 使用了错误的链接描述文件。调试时必须使用 “-i” ICD 链接描述文件。（例
如，必须使用 16F887i.lkr，而不是 16F887.lkr）。

9. 目标应用程序尝试使用为调试执行程序保留的资源，导致调试执行程序损坏。例
如，目标应用程序向保留的文件寄存器中写入数据。请参见第 4.4.2 节 “保留的
资源”。

10. 对于 PIC24 和 dsPIC® DSC 器件，在 “Comm Channel Select”配置位中选择
了错误的 PGXn/EMUXn 端口。检查是否选择了 PICkit 2 Debug Express 所连接
的端口。

11. 可能是所使用的配置设置使目标器件无法正常工作和执行代码。如果无法执行代
码，目标器件将无法进入调试模式。

12. 器件受到代码保护。检查配置位来确定代码保护设置。

13. 可能在无效的上下文中尝试执行操作。例如，如果目标应用程序当前正在运行，
PICkit 2 Debug Express 将无法设置断点。

PK2Error0029:Failed PICkit 2 operation

说明：PICkit 2 Debug Express 无法完成某个调试操作，例如“Halt”或“Step”操作。

建议操作：请参见 PK2Error0028 的建议操作。

PK2Error0030:Failed to read target file registers

说明：PICkit 2 Debug Express 无法读取一个或多个目标文件寄存器。

建议操作：请参见 PK2Error0028 的建议操作。

PK2Error0031:I/O Operation timeout

说明：PICkit 2 USB 操作超时。

建议操作：重试操作。如果继续出现失败，则将 PICkit 2 设备从 USB 和目标板上取下，
重启 PC，将 PICkit 2 设备重新连接到 USB，然后重试操作。如果这样做不起作用，则
尝试使用 PICkit 2 编程器应用程序来更新固件。

PK2Error0032:Failed Blank Check (Address - Expected Value - Value Read)

说明：空白检查操作失败。错误消息中会指明所涉及的存储器类型和地址，并显示期望
的空白值和实际读取值。 

建议操作：尝试擦除器件。如果擦除之后，器件不为空白，则检查 ICSP 连接，如第 3 章
“使用在线串行编程（ICSP™）”中所述。如果目标器件具有 AVDD 和 AVSS 引脚，请检
查它们是否正确连接。根据器件数据手册，确认 PIC18FXXJXX、 PIC24X 和 dsPIC33F

注： 当从目标器件读取到第一个错误值时， PICkit 2 Debug Express 会终止空白
检查操作。所以将只会报告这第一个错误值。可能还存在其他错误值。
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器件在 VDDCORE/VCAP 引脚上接有适当的电容。对于一些 PIC18F 器件，VDD 引脚上可能
需要高达 10 uF 的电容，这样才能正确进行擦除。

PK2Error0033:User aborted operation

说明：如果 PICkit 2 Debug Express 弹出了一个警告，并且用户选择取消当前操作，则
通常会显示该错误。例如，PICkit 2 Debug Express 可能会警告：当禁止 MCLR 引脚时，
无法对调试目标器件进行编程。如果用户单击警告窗口中的 Cancel，编程操作将被终
止，并显示该错误。

建议操作：无。

PK2Error0034:Failed to Initialize

说明：PICkit 2 Debug Express 组件无法完成它的初始化序列。   
建议操作：这可能是由于安装不完整或已损坏导致的。请参见 PK2Error0002 的建议
操作。

PK2Error0035:Failed to retrieve XML Data (node)
PK2Error0036:Failed to open PK2 Script File (filename)
PK2Error0037:PK2 Script File structure size mismatch (struct internal size 
file size)
PK2Error0038:Unable to fit block in IO buffer (MemType Direction 
Blocksize)

说明：PICkit 2 Debug Express 内部错误。

建议操作：这可能是由于安装不完整或已损坏导致的。请参见 PK2Error0002 的建议
操作。

PK2Error0039:Not halted in debug executive

说明：目标器件正在运行应用程序代码时，尝试执行只有在目标器件暂停时才能完成的
操作。如果 PICkit 2 Debug Express 无法暂停目标器件，则可能出现该错误。

建议操作：重试操作之前，先暂停目标器件。

PK2Error0040:Operation not supported for current device

说明：当前器件不支持所尝试的调试操作。 
建议操作：无。

PK2Error0041:Failed to create Stream
PK2Error0042:Failed Stream Read
PK2Error0043:Failed IStream Write
PK2Error0044:Failed IStream Open
PK2Error0045:No STATSTG
PK2Error0046:Failed IStream Read
PK2Error0047:Failed Stream Write

说明：PICkit 2 Debug Express 内部错误。

建议操作：这可能是由于安装不完整或已损坏导致的。请参见 PK2Error0002 的建议
操作。
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注：
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第 6 章  更新 PICkit 2 操作系统
6.1 简介

本章描述如何更新 PICkit 2 开发编程器 / 调试器的操作系统 （固件）。

• 更新 PICkit 2 操作系统——PICkit 2 编程器应用程序

• 更新 PICkit 2 操作系统——MPLAB IDE

6.2 更新 PICkit 2 操作系统——PICkit 2 编程器应用程序

启动 PICkit 2 编程器应用程序后，它会检查 PICkit 2 的固件版本，确定它是否是最新
版本。如果不是，它会尝试自动下载最新版本 （图 6-1）。

图 6-1： 更新 PICkit™ 2 操作系统警告

如果自动下载出错，或者您需要不同的操作系统 （OS），或者得到指示需要这么做，
可以手动更新操作系统。

要手动更新 PICkit 2 固件 / 操作系统，请完成以下步骤：

1. 从 Microchip 网站（www.microchip.com）下载最新的 PICkit 2 固件 / 操作系统，
并将文件保存到 PICkit 2 安装目录中。默认情况下，位置是：
C:\Program Files\Microchip\PICkit 2 v2
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2. 选择 Tools>Download PICKit 2 Operating System，如图 6-2 所示。

图 6-2： 下载 PICkit™ 2 操作系统

3. 浏览至保存了最新固件 / 操作系统文件的目录。

4. 选择 PK2*.hex文件并单击 Open 按钮。

操作系统的更新进度将显示在编程软件的状态条中，同时 PICkit 2 上的 Busy 
LED 将闪烁。成功完成更新后，状态条将显示 “Operating System Verified”
（操作系统已校验），同时 Busy LED 熄灭。此时固件 / 操作系统更新完成。

6.3 更新 PICkit 2 操作系统——MPLAB IDE
在 MPLAB IDE 中选择 PICkit 2 作为调试工具或编程器时， MPLAB IDE 将会检查
PICkit 2 的固件版本，确定是否是最新版本。如果不是，它会尝试自动下载最新版本。
Output 窗口的 PICkit 2 选项卡中会记录它的进度 （图 6-3）。

图 6-3： 更新 PICkit™ 2 操作系统的进度

如果自动下载出错，或者您需要不同的操作系统 （OS），或者得到指示需要这么做，
可以手动更新操作系统。

要手动更新 PICkit 2 固件 / 操作系统，请完成以下步骤：

1. 从 Microchip 网站（www.microchip.com）下载最新的 PICkit 2 固件 / 操作系统，
并将文件保存到 PICkit 2 安装目录中。默认情况下，位置是：
C:\Program Files\Microchip\MPLAB IDE\PICkit 2

2. 选择 PICkit 2 作为调试工具 （Debugger>Select Tool>PICkit 2）或编程器
（Programmer>Select Programmer>PICkit 2）。
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3. 选择 Debugger>Download OS 或 Programmer>Download OS，如图 6-4 所示。

图 6-4： 在 MPLAB® IDE 中下载 PICkit™ 2 操作系统

4. MPLAB IDE 会开始将最新的固件 / 操作系统文件下载到 PICkit 2 中。操作系统更
新的进度会显示在Output窗口的PICkit 2选项卡中，并且PICkit 2上的Busy LED
会闪烁。成功完成更新时， PICkit 2 选项卡中的文本将指示 “PICkit 2 Ready”
（PICkit 2 就绪）， Busy LED 将熄灭。此时固件 / 操作系统更新完成。
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第 7 章  PICkit 2 UART 工具
7.1 简介

PICkit 2 编程器应用程序 V2.40 和更高版本中包含 UART Tool（UART 工具）功能。该
功能使PICkit 2可以用作串行UART终端接口，与PIC单片机进行通信。可能的用途包括：

• 显示来自单片机的调试文本输出

• 将单片机数据记录到文本文件中

• 开发和调试单片机 UART 接口

• 在开发过程中与单片机接口和向单片机发送命令

该工具支持从 150 至 38400 波特率 （包括定制的非标准波特率）的全双工异步串行通
信。 PICkit 2 通过 ICSP 连接器直接连接到采用逻辑电平的单片机 TX （发送）和 RX
（接收）引脚，不需要收发器。

7.2 连接 PICkit 2 UART 工具

PICkit 2 按图 7-1 中所示方式连接到目标串行端口。PICkit 2 TX 信号（输出）应连接到
目标 RX 信号（输入），而 PICkit 2 RX 信号（输入）应连接到目标 TX 信号（输出）。

与 UART 工具配合使用时，根据应用程序版本，PICkit 2 可能无法为目标器件提供 VDD
电压。请参见 PICkit 2 自述文件中的版本说明。不过，即使在 PICkit 2 不提供目标 VDD
时，也必须将 PICkit 2 VDD 引脚连接到目标 VDD 电压，否则它将无法进行通信。

PICkit 2 UART 工具将使用 2.5V 至 5.0V 的目标 VDD 电压工作。

图 7-1： PICkit™ 2 UART 工具

1
2
3
4
5
6

* 此 6 引脚插头 （0.100" 间距）可连接 0.025" 的方形引脚。

引脚说明 *

1 = 无连接

2 = VDD 目标电源

3 = VSS （地）

4 = RX （PICkit 2 输入）

5 = TX （PICkit 2 输出）

6 = 无连接

引脚 1 指示标记
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引脚 4 和 5 上的串行信号的格式会被反相，从而使启动位 = 逻辑低电平（VSS），停止
位 = 逻辑高电平 （VDD）。串行数据格式始终为：8 数据位，无奇偶校验，具有一个停
止位。

PICkit 2 设备上的 BUSY LED 用作串行连接的活动指示灯。

7.3 PICKIT 2 UART TOOL 窗口

要打开 PICkit 2 UART Tool 窗口，请选择 Tools>UART Tool…（图 7-2）。此时，PICkit 2
编程器窗口将打开，PICkit 2 编程器应用程序窗口将关闭，因为在 UART 工具处于工作
状态时，不能使用编程器，反之亦然。

图 7-2： PICkit™ 2 UART TOOL 窗口 ASCII 模式

UART 工具有两种模式：ASCII 和 HEX。当前模式通过显示屏幕右上角的按钮来选择和
显示。对应于工作模式的按钮将显示为被按下的效果。例如，在图 7-2 中，ASCII 模式
处于工作状态，所以 ASCII 按钮显示为被按下的效果。

模式选择会影响串行数据在窗口中的显示和输入，随后两节将对这两种模式进行说明。

注： 即使 PICkit 2 可能不提供目标 VDD，也必须将 PICkit 2 VDD 引脚连接到目标
VDD 电压，否则它将无法进行通信。

警告

PICKIT 2 UART 工具仅针对逻辑电平信号使用。不要将 PICkit 2 UART 工具连接到 RS-232 
+/- 12V 信号！这样做可能导致 PICkit 2 设备、计算机 USB 端口和目标串行端口损坏。
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窗口可以通过单击并拖动窗口右下角来调整大小。

7.3.1 设置波特率并连接

波特率可以从 UART Tool 窗口左上角的组合框中进行选择。其中会列出几个常用波特
率，通过选择“Custom...”（定制），可以以 1 波特为递增单位，使用从 150 至 38400
的任何波特率 （图 7-3）。

图 7-3： 波特率选择

设置了某个定制波特率之后，该波特率将在波特率选择框中显示为最后一项（图 7-4）。
每次只能设置一个定制波特率。再次选择 “Custom...”可以更改定制波特率。

图 7-4： 定制 14400 波特率

选择波特率之后，单击 Connect （连接）以选定的波特率使能 UART 工具串行接口。
使能串行接口之后，可以通过单击 Disconnect （断开连接）禁止它。波特率只能在接
口断开时进行更改。

7.3.2 ASCII 模式

选择 ASCII 模式时，从目标器件的 UART 接收的串行字节将在主窗口终端显示屏幕中
显示为 ASCII 字符。所有字节将连续地显示。要显示新的一行，目标 UART 必须按顺
序发送字符值 0x0D （回车）和 0x0A （换行）。如果仅发送其中一个值，或以逆序发
送这些值，字符将在显示屏幕中显示为不可打印字符 （方框）。

字节可以通过三种方式发送：

1. 单击终端显示屏幕来选择它。在PC键盘上输入的任何字符都会立即从PICkit 2发
送出。

2. 右键单击终端显示屏幕，并从弹出菜单中选择 Paste （粘贴）来粘贴先前复制或
剪切的任意文本。也可以使用 <Ctrl> + <v>。粘贴的所有数据将立即从 PICkit 2
发送出。

3. 使用窗口底部的 “String Macros”（字符串宏）。
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如果未选中“Echo On”复选框，则不会显示任何已发送的字符。如果选中该复选框，
在终端显示屏幕中将显示已发送的字符和已接收的字符。

显示屏幕底部的 “String Macros”允许最多输入 4 个字符串。每个字符串的长度最多
可以为 60 个字符。单击某个字符串旁的 Send （发送）时，整个字符串将按顺序从
PICkit 2 发送出。即使不使用 UART 工具时，“String Macros”字符串也会被保存。

如果选中字符串宏框上方的“Append CR+LF”复选框，则单击 Send 时，将会在字符
串末尾自动发送回车（0x0D）和换行（0x0A）字符。未选中时，在字符串字符后不会
发送任何字符。

终端显示屏幕中的文本可以使用光标选择 （高亮显示），并通过单击右键并选择 Copy
（复制），或按 <Ctrl> + <c> 复制到剪贴板中。

7.3.3 Hex 模式

UART工具Hex模式会在终端显示屏幕中显示从目标器件的UART接收到的字节的十
六进制值。

UART 工具接收到的每一行字节数据的开头会带有文本 “RX:”。

UART 工具发送的每一行字节数据的开头会带有文本 “TX:”。

在图 7-5 中，从目标器件接收到 4 个 hex 字节 0x50、0x4B、0x53 和 0x41（先接收到
0x50）。然后，发送 3 个字节 0x70、 0x6B 和 0x32 （先发送 0x70）。

在 Hex 模式下，只能通过一种方式发送字节：在 4 个“Send Hex Sequences:”（发送
Hex 序列）框的其中一个中输入一个或多个十六进制值组成的序列。要发送序列，请单
击它旁边的 Send。十六进制序列可以包含 1 至 48 个字节。

“Echo On”复选框在 Hex 模式下没有作用。

终端显示屏幕中的数据可以使用光标选择（高亮显示），并通过单击右键并选择 Copy，
或按 <Ctrl> + <c> 复制到剪贴板中。
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图 7-5： PICKIT™ 2 UART TOOL 窗口 HEX 模式

7.3.4 Wrap Text （文本折行）

该复选框会同时影响 ASCII 和 HEX 这两种模式。选中时，显示的数据行会在终端显示
屏幕的右侧边缘自动折行。如果未选中，那么接收到的数据行不会折行，在终端显示屏
幕中将显示一个水平滚动条，以允许查看整个数据行。

终端显示将在缓冲区中保留已接收数据的最后 200 行。垂直滚动条可以用于查看先前的
数据或文本。

7.3.5 Log to File （记录到文件中）

Log to File 按钮使得可以将所有文本和数据按它在显示屏幕中的显示内容保存到文本
文件中。

单击 Log to File 打开 Save File（保存文件）对话框。指定文件位置和名称，然后单击
Save （保存）。在将终端显示屏幕内容保存到日志文件中时， Log to File 按钮将变为
绿色，并显示文本 “Logging Data...”（正在记录数据）。 （图 7-6）

图 7-6： 正在将数据记录到文件中
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要停止从显示屏幕中记录数据并关闭日志文件，请单击 Logging Data...。

7.3.6 Clear Screen （清屏）

单击 Clear Screen 按钮可以从终端显示窗口中清除所有文本或数据。如果正在将数据
记录到文件中，清屏将不会影响日志文件。

7.3.7 退出 UART 工具

单击 Exit （退出）关闭 UART Tool 窗口，并返回到 PICkit 2 编程器应用程序主窗口。
在任何编程操作期间， UART 工具终端显示数据和设置将会被保存，直到重新进入
UART 工具为止。

如果 PICkit 2 应用程序关闭，UART 工具设置（包括 String Macros 和 Hex Sequences）
将会被保存，并在下一次使用 UART 工具时恢复。应用程序关闭时，终端显示缓冲区文
本和数据不会被保存。

注： 只有在日志文件打开后在显示屏幕中显示的数据才会被写入日志文件。现有
的数据不会被保存。要保存现有的数据，请使用 Copy 和 Paste。
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附录 A MPLAB IDE 参考
A.1 简介

在 MPLAB IDE 中，先选择 PICkit 2 支持的器件，然后从 Debugger 或 Programmer 菜
单中选择 “PICkit 2”，分别向 MPLAB IDE 中增加调试或编程功能。本附录概述所增
加的功能。关于将 PICkit 2 开发编程器 / 调试器与 MPLAB IDE 配合使用的更多信息，
请参见第 4 章 “PICkit 2 Debug Express”。

• 调试功能

• 编程功能

• Settings 对话框

此外，MPLAB IDE状态条中会增加“PICkit 2”，Output对话框中会增加PICkit 2选项卡。

关于使用 PICkit 2 Debug Express 的常见问题，以及 PICkit 2 MPLAB IDE 错误代码的
描述，另请参见第 5 章 “疑难解答”。

A.2 调试功能

从 Debugger 菜单中选择 PICkit 2 时，在以下 MPLAB IDE 功能中将会增加调试项：

• 调试器菜单

• 鼠标右键按钮菜单

• 工具栏

A.2.1 调试器菜单

Run （运行） F9
执行程序代码，直到遇到断点或直到选择 Halt。
代码从当前程序计数器处 （如状态条中所示）开始执行。当前程序计数器位置还会在
Program Memory 窗口中显示为一个指针。当程序在运行时，几个其他功能会被禁
止。

Animate （连续单步运行）

连续单步运行使调试器在运行时实际上执行单步操作，并在运行时更新寄存器的值。

连续单步运行的运行速度低于 Run 功能，但它使您可以在 Special Function Register 窗
口或在 Watch 窗口中查看不断变化的寄存器值。

要暂停连续单步运行，请使用菜单选项 Debugger>Halt、工具栏 Halt 或 <F5>。

Halt （暂停） F5
暂停 （停止）程序代码的执行。单击 Halt 时，状态信息会被更新。
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Step Into （单步运行） F7
单步运行程序代码。

对于汇编代码，该命令执行一条指令（单周期或多周期指令），然后暂停。执行一条指
令之后，所有窗口都会被更新。

对于 C 代码，该命令会执行一行 C 代码 （这意味着可能执行一条或多条汇编指令），
然后暂停。执行之后，所有窗口都会被更新。

Step Over （单步跳过） F8
在 C 代码中，单步跳过当前的代码行。

Step Out （单步跳出）

不可用。

Reset （复位） F6
向目标处理器发出复位序列。这会发出 MCLR 信号，将程序计数器复位为复位向量。

Breakpoints （断点）

打开 Breakpoint 对话框。在该对话框中设置、使能或禁止断点。关于该对话框的更多信
息，请参见 MPLAB IDE 在线帮助文件。

Program （编程）

将代码下载到目标器件中。

Read （读）

读目标存储器。信息会被上传到 MPLAB IDE。

Read EEData （读 EEData）
读目标 EEData 存储器。信息会被上传到 MPLAB IDE。

Connect （连接）

尝试建立或重新建立 PC 和 PICkit 2 之间的通信。该连接的进度显示在 Output 对话框
的 PICkit 2 选项卡中。

Download OS （下载操作系统）

下载最新的 PICkit 2 操作系统。

Settings （设置）

打开 PICkit 2 Settings 对话框（见第 A.4 节“Settings 对话框”）。设置自动选项和使
能 / 禁止警告。

A.2.2 鼠标右键按钮菜单

在代码显示中 （例如程序存储器和源代码文件），鼠标右键菜单中会显示以下选项：

Set/Remove Breakpoint （设置 / 去除断点）

在当前选定行设置或去除断点。

注： 不要单步执行 SLEEP指令。

注： 您也可以右键单击或双击某个代码行来设置简单断点。
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Enable/Disable Breakpoint （使能 / 禁止断点）

在当前选定行使能或禁止断点。

Breakpoints （断点）

去除、使能或禁止所有断点。

Run To Cursor （运行到光标位置）

程序运行到当前光标位置。原为 Run to Here （运行到此处）。

A.2.3 工具栏

当选择 PICkit 2 作为调试器时， MPLAB IDE 中会显示以下工具栏：

• 标准调试工具栏（Run、Halt、Animate、Step Into、Step Over、Step Out 和 Reset）。

• PICkit 2 调试工具栏 （Program、 Read、 Read EEData 和 Connect）。

A.3 编程功能

从 Programmer 菜单中选择 PICkit 2 时，在以下 MPLAB IDE 功能中将会增加编程项：

• 编程器菜单

• 工具栏

A.3.1 编程器菜单

Program （编程）

对如下存储区进行编程：程序存储器、 EEDATA 存储器、配置位和 ID 单元。

Read （读）

读如下存储区：程序存储器、 EEDATA 存储器、配置位和 ID 单元。

Verify （校验）

校验如下存储区的编程：程序存储器、 EEDATA 存储器、配置位和 ID 单元。

Erase （擦除）

擦除器件上的所有数据，包括程序存储器、 EEDATA 存储器、 ID 和配置位。

Blank Check （空白检查）

检查是否所有器件存储器都已擦除 / 空白。

Read EEDATA （读 EEDATA）

读 EEDATA 存储器。

Connect （连接）

在 PICkit 2 和 PC 之间建立通信。

Download OS （下载操作系统）

下载 PICkit 2 操作系统 / 固件。

Release from Reset （从复位状态释放）

将 MCLR 设置为 VDD。
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Hold in Reset （保持复位）

将 MCLR 设置为地 （0）。

Settings （设置）

打开 PICkit 2 Settings 对话框（见第 A.4 节“Settings 对话框”）。设置自动选项和使
能 / 禁止警告。

A.3.2 工具栏

Program the target device （对目标器件进行编程）

对如下存储区进行编程：程序存储器、 EEDATA 存储器、配置位和 ID 单元。

Read target device memories （读目标器件存储器）

读如下存储区：程序存储器、 EEDATA 存储器、配置位和 ID 单元。

Read the target EEDATA memory （读目标 EEDATA 存储器）

读 EEDATA 存储器。

Verify the contents of the target device （校验目标器件的内容）

校验如下存储区的编程：程序存储器、 EEDATA 存储器、配置位和 ID 单元。

Erase the target device memories （擦除目标器件存储器）

擦除器件上的所有数据，包括程序存储器、 EEDATA 存储器、 ID 和配置位。

Verify that target memories are erased （验证目标存储器是否已擦除）

检查是否所有器件存储器都已擦除 / 空白。

Release from Reset （从复位状态释放）

将目标 MCLR 引脚设置为 VDD。

Hold in Reset （保持复位）

将目标 MCLR 引脚设置为 VSS。

Connect （连接）

在 PICkit 2 和 PC 之间建立通信。
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A.4 SETTINGS 对话框

选择Debugger>Settings或Programmer>Settings打开Settings对话框，并设置PICkit 2。

A.4.1 Settings 选项卡

PICkit 2 Settings 对话框的该选项卡用于设置自动选项。

A.4.2 Warnings 选项卡

PICkit 2 Settings 对话框的该选项卡用于使能或禁止在 Output 窗口中显示的警告消息。

• 要使能 / 禁止特定消息，请单击消息旁边的复选框，以选中 / 取消选中它。

• 要使能 / 禁止所有消息，请单击 Check All/Uncheck All（选中全部 / 取消选中全
部）。

Connect on startup
（启动时连接）

当选择 PICkit™ 2 作为编程器时，立即尝试连接。

Program on 
successful build
（成功编译时烧写）

当项目编译成功时，立即尝试使用更新后的代码来烧写器件。

Run after successful 
program
（成功烧写后运行）

当器件烧写成功时，立即尝试运行程序。

Output to debug file
（输出到调试文件）

每当程序运行时，将调试信息输出到文件中。
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注：
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附录 B PICkit 2 原理图
本附录给出了 PICkit 2 开发编程器 / 调试器的原理图。演示板原理图位于其相应的用户
指南中。

图 B-1： PICkit™ 2 原理图 （第 1 页，共 2 页）
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图 B-2： PICkit™ 2 原理图 （第 2 页，共 2 页）
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